1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

RPi + OpenELEC All LEDS blue when no input signal

Discussion in 'Software Support' started by itfcjim, 1 June 2016.

  1. 5p4rtan

    5p4rtan New Member

    Messages:
    2
    Hi,
    I know its an old thread but during my search I often missed a (final) sollution.

    Its not the ultimate sollution but maybe it helps a bit :)

    Im using WS2812b and therefore an arduino for driving the LEDs.
    With it I measure the USB Vltage of on of my TVs USB Ports and stop output if it is low (TV is off).

    In the next step I will create a script on the raspberry that start and stops the hyperion service depending on the USB state :)
     
  2. mg3point

    mg3point New Member

    Messages:
    17
    Hardware:
    RPi3
    My pi is currently powered from my tv's usb slot so when the tv is on, the pi is running. My lights are currently powered from a switch I placed in the back of my entertainment stand. I have however always planned to automate that as well. Could you perhaps wire in a relay to the pi and tell it to close the relay when the pi has power?
     
  3. 5p4rtan

    5p4rtan New Member

    Messages:
    2
    Yes, that was my intent as well but I decided to control it on the software site as my led power supply also powers my pi :D
    Be aware that most tv havent a current regulator in the usb port and could blow up. I hope you double checked it could deliver enough current for your pi.

    So for you its easy to connect a relays or fet on one of the gpios and configure it in the boot setup like init.d as described here http://raspberrypi.stackexchange.com/questions/4664/setting-gpio-value-on-boot