1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Alpha Android Screen Grabber

Discussion in 'Development' started by abrenoch, 16 February 2018.

  1. Indiglo

    Indiglo New Member

    Messages:
    9
    Hi guys! Any more news? :)
     
  2. abrenoch

    abrenoch Android Grabber Developer

    Messages:
    80
    Hardware:
    RPi1/Zero, RPi2
    That adapter I linked to + a pi zero = awesome. Works wight out of the box, got hyperion up and running on it no problem at all! Really clean and cheap way to set a device up, just solder a few wires to the GPIO and you are good to go.

    The adapter we were talking about does seem to work! The app I was using had the image a bit squished horizontally, and quality is not great at all, but it does work. Personally, I wouldn't use it for anything, but that's just me. Really cool that is even possible though!
     
  3. Ziggy73701

    Ziggy73701 New Member

    Messages:
    4
    Hardware:
    RPi2
    Just seen this... looks awesome!!!! I am running this on a NVidia shield, connected to a PI with LED's all that works spot on.... UNTIL I run SPMC and then it doesn't work. Lights just do dark... any suggestions?
     
  4. Indiglo

    Indiglo New Member

    Messages:
    9
    Try do change settings related to the video codecs within SPMC.
     
  5. Ziggy73701

    Ziggy73701 New Member

    Messages:
    4
    Hardware:
    RPi2
    I disabled the addon completely.... then removed it... to avoid any conflicts. Its very odd... as all else seems pretty good
     
  6. Indiglo

    Indiglo New Member

    Messages:
    9
    I'm talking about this. Try to remove one by one and see if it works.
     

    Attached Files:

  7. Ziggy73701

    Ziggy73701 New Member

    Messages:
    4
    Hardware:
    RPi2
    I ended up just resetting my install, which resolved it. I must have had something weird set somewhere.
    For an alpha it works well... Little flakey but really impressed with what seen so far!
     
  8. UniCizin

    UniCizin New Member

    Messages:
    6
    Hardware:
    RPi1/Zero
    Hey Guys..
    Just got me a Sony Bravia with Android TV and was excited to read about the Android grabber.
    Unfortunately i Cant Set the Hyperion service IP..
    When i enter it anderen click Finish, the Button cancel is selected and cannot bei changed (via remote) so the IP always stays empty.

    Amy ideas?

    (Sry for the typing, German Autocorrect is involved)
     
  9. abrenoch

    abrenoch Android Grabber Developer

    Messages:
    80
    Hardware:
    RPi1/Zero, RPi2
    Hey Uni, that is probably because I shoehorned a mobile UI to work on android TV. Some of the inputs are a bit different for android TV, and I just haven't been able to wrap up the version made just for aTV (making an android TV interface sucks lol, a lot more work it seems). I've had a lot fall on my plate the past couple weeks and simply have not had much time to work on this.

    That being said, once you type in the IP, try hitting the back button on your remote, which should hide the on-screen keyboard (at least the shield does). Once the keyboard is hidden you should be able to press the 'right arrow' button on your remote to select the save button. I'm fairly certain once I get things ported over that won't be an issue anymore!
     
  10. UniCizin

    UniCizin New Member

    Messages:
    6
    Hardware:
    RPi1/Zero

    this worked indeed. now, all the menus get grabbed and the LEDs light up.
    They stay black at YouTube, Netflix and so on, but even the home menu sends light-informations.

    could this be a "layer"-problem? So you capture the top-Sony-AndroidTV-Layer-thing that lays above the video?
    I did not yet had time to check the sourcecode for any hints..
     
  11. abrenoch

    abrenoch Android Grabber Developer

    Messages:
    80
    Hardware:
    RPi1/Zero, RPi2
    It seems like maybe youtube on different devices may behave in different ways... I'm afraid I'm just not knowledgeable enough on the topic to say for certain. You could try one of the alternate youtube apps linked earlier in the thread and see if you have any better luck with that!
     
  12. abrenoch

    abrenoch Android Grabber Developer

    Messages:
    80
    Hardware:
    RPi1/Zero, RPi2
    Also, if anybody is interested in joining the beta channel (in the play store) for the app check the original post for instructions!

    It is only available for mobile on there right now (still need to finish the atv build), but wanted to make people aware!
     
  13. UniCizin

    UniCizin New Member

    Messages:
    6
    Hardware:
    RPi1/Zero
    hmm youtube is not my top priority ..
    Netflix / Amazon Prime and the HDMI Sources are more important, as i dont find a good "hdmi grabber" for 4k HDR stuff...
     
  14. Gershy13

    Gershy13 New Member

    Messages:
    28
    Hardware:
    RPi2
    yup this is what im looking for too... a cheap 4k hdr grabber for hdmi.
     
  15. UniCizin

    UniCizin New Member

    Messages:
    6
    Hardware:
    RPi1/Zero
    But i'd prefer an internal grabber as the Bravia streaming Apps have better Picture Quality :/
     
  16. peter

    peter Member

    Messages:
    108
    Hardware:
    RPi1/Zero, RPi2, RPi3
    Hi there, what do you think about "Android TV Framework" for this purpose? Can it be helpful for grabbing screen from various input sources?
     
  17. DerDominik

    DerDominik New Member

    Messages:
    5
    Hardware:
    RPi2, 32/64bit
    App looks great! Thanks for that work :)
    It is possible to configure an autostart of the app/service with system start? Or do I've to start manually everytime?
     
  18. abrenoch

    abrenoch Android Grabber Developer

    Messages:
    80
    Hardware:
    RPi1/Zero, RPi2
    Glad it is working for ya!

    Automatically starting the grabber when the system boots is something I definitely want to do... I actually started working on it but ran into some issues I'm not sure how to confront just yet (basically that little confirmation dialog that pops up has to be called every time the screen needs to be captured, and calling it from a background service is looking a little difficult). Ideally it would just start, but I might have to make the grabber request focus for a split second and then close the app.

    If anyone reading this knows what I'm talking about and has any ideas I'm all ears!
     
  19. Nico51

    Nico51 New Member

    Messages:
    10
    Hardware:
    RPi2
    Hi.

    I have Nvidia Shield TV and Sony KD65A1.
    On my Shield it work in the main menu, in Plex, in Kodi and in YouTube: Super! Netflix and MolotovTV don’t work.
    On my TV (Android TV 7.0) it work in the main menu but don’t work with Plex, Kodi, Youtube, Netflix and MolotovTV. It dont work too with the enebbed tv tuner.
    I have try to use the alternate opengl grabber without success. The « grab on boot » is impossible to activate.

    Sorry for my English. I am French
     
  20. daisy-alex

    daisy-alex New Member

    Messages:
    2
    Hardware:
    RPi3, +Arduino
    Thanks for the app. On TV Box there were problems. Light-emitting diodes shine only from above and from below. At the left and on the right it is dark.