1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

RPi + Other Software apa102 not work

Discussion in 'Software Support' started by huerso, 9 June 2019.

  1. huerso

    huerso New Member

    Messages:
    3
    Hardware:
    RPi3
    Hello, forgive my English, it's a translation.

    I have replaced LED WS2812 with an APA102, now nothing works and it is connected in the same way as the previous installation.
    I wonder if I need something else to connect leds apa102 to the raspberry, some manual about it?

    Thank you
     
  2. Arakon

    Arakon Member

    Messages:
    149
    Hardware:
    RPi1/Zero, RPi3, +Arduino
    Did you actually adjust your config file to the new LED type?
     
  3. huerso

    huerso New Member

    Messages:
    3
    Hardware:
    RPi3
    Yes, I have configured apa102 in the configuration.

    I have read that a 3.3v / 5v logical converter is needed but now I only have the one that I attached in photo ......... would it be valid?

    [​IMG] thanks
     
  4. huerso

    huerso New Member

    Messages:
    3
    Hardware:
    RPi3
    Hello, please, can you tell me if that converter could work in my configuration?

    How would I have to connect it?

    can you please tell me something, and what can I do
     
  5. TPmodding

    TPmodding Administrator Staff Member Administrator

    Messages:
    1,273
    Hardware:
    RPi1/Zero, RPi2, RPi3, +Arduino, +nodeMCU/ESP8266
    should work yes, the input pins are going to rpi and the output pins to the leds