1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Code rgb inversé

Discussion in 'French Talk' started by thouve, 29 April 2019.

  1. thouve

    thouve New Member

    Messages:
    8
    Hardware:
    RPi1/Zero, RPi3, 32/64bit, +Arduino, +PhilipsHue
    Bonjour a tous, nouveau ici, je me suis inscrit car j ai un probleme que je ne vois nulle part ailleurs.
    J ai une bande led ws2812b branché sur le gpio18 de mon rpi.
    Lorsque j ai démarré mon osmv, j ai trouvé que les couleurs etait etrange car rien ne correspond.
    En fouillant avec les code rgb, je remarque que les données sont "inversées", je m explique :
    Quand je dois avoir du rouge (255,0,0) j obtiens du cyan(0,255,255)
    Quand je dois avoir du vert(0,255,0) j'obtiens du magenta(255,0,255)
    Et pour le bleu(0,0,255) j'obtiens du jaune(255,255,0)
    Pareil pour le noir(0,0,0) j'obtiens donc du blanc(255,255,255)

    Jaumerai donc comprendre d'où cela peut venir. Si certains on eu le probleme, comment le resoudre?
    Car j'essaie de vendre ca a ma femme ppur la tv du salon mais en l'état je risque pas d avoir une validation ^^

    Merci d'avance pour votre aide, en esperant pouvoir resoudre ce soucis.
     
  2. Ppn

    Ppn New Member

    Messages:
    17
    bonjour,

    dans ton fichier hyperion config, il faut peut-être inversé l'ordre dans la ligne RGB, tu peux essayer GRB ou BRG etC...
     
  3. thouve

    thouve New Member

    Messages:
    8
    Hardware:
    RPi1/Zero, RPi3, 32/64bit, +Arduino, +PhilipsHue
    Merci mais ce n eqt pas ca le soucis

    Le soucis est vraiment au niveau transmission du code rgb.
    J obtiens 255 quand je dois obtenir 0 etc
     
  4. Ppn

    Ppn New Member

    Messages:
    17
    Désolé je vois pas trop alors mais C’est peut-être une mauvaise configuration de Hyperion. Essaye de reprendre les tuto à zéro