1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Direct connection ws2812b to RPI3 or use Arduino pro mini

Discussion in 'Hyperion General' started by fr3sh, 6 July 2016.

  1. Draq

    Draq New Member

    Messages:
    17
    well it worked once, somehow, but not working again anymore, was some luck, I was restarting the pi while I was sending with hypercon some colors to it, and somehow it worked.. but now not anymore.. it feels something happens wrong

    ssh out: hyperion-remote -c bfff5e
    ssh in: hyperion-remote:
    ssh in: version : V1.03.4 (brindosch-c750c41/dc6a602-1522918225
    ssh in: build time: Apr 5 2018 01:57:05
    ssh in: Connected to localhost:19444
    ssh in: Set color to 191 255 94
    ssh out: Error while reading data from host
     
  2. Arakon

    Arakon Member

    Messages:
    151
    Hardware:
    RPi1/Zero, RPi3, +Arduino
    That error usually means hyperion isn't running anymore for some reason.
     
    • Agree Agree x 1
  3. Draq

    Draq New Member

    Messages:
    17
    ssh in: version : V1.03.4 (brindosch-c750c41/dc6a602-1522918225
    ssh in: build time: Apr 5 2018 01:57:05
    ssh in: Connected to localhost:19444
    ssh in: Set color to 137 255 140
    ssh out: hyperion-remote -c ffb897
    ssh in: hyperion-remote:
    ssh in: version : V1.03.4 (brindosch-c750c41/dc6a602-1522918225
    ssh in: build time: Apr 5 2018 01:57:05
    ssh in: Connected to localhost:19444
    ssh in: Set color to 255 184 151

    Now it works, somehow I have to be lucky and send the colors before the raspberry pi loads fully and then it works.. but not always, what could be the issue? what ca be wrong? I am using same as you everything. Why sometimes it works and sometimes not.

    What tests should I do, any idea? to figure out exact issue?


    "Now I pressed "stop" and "start", and its over, won't work anymore.


    [email protected]:~ $ pidof hyperiond
    1003
     
  4. Arakon

    Arakon Member

    Messages:
    151
    Hardware:
    RPi1/Zero, RPi3, +Arduino
    • Agree Agree x 1
  5. Draq

    Draq New Member

    Messages:
    17
    With Arduino Nano it works, but I don't want to use that. I'll try the level converter solution, and see if this solves the issue, you think that's the reason why after boot is not working anymore? if I restart the hyperion?
     
  6. Arakon

    Arakon Member

    Messages:
    151
    Hardware:
    RPi1/Zero, RPi3, +Arduino
    No idea. I only tried it on my desk for experimentation's sake, and it seemed to work fine, I was able to send color changes and got the rainbow at any time, even without the shifter.
     
    • Agree Agree x 1
  7. Draq

    Draq New Member

    Messages:
    17
    I have new updates, the thing acts exactly like this:

    When I first boot PI, I can send colors from HyperCon without problems and it changes.

    If I press "stop" and then "start" in HyperCon, then its over, won't work and connection to host will fail.

    It feels that if rasp fully boot and I start hyperion it doesn't work anymore, but if it boot and meanwhile hyperion loads then it works..

    Can you try stop/start? and change oclors?
     
  8. Arakon

    Arakon Member

    Messages:
    151
    Hardware:
    RPi1/Zero, RPi3, +Arduino
    I can in the evening, I'm about to leave for work.
     
  9. Draq

    Draq New Member

    Messages:
    17
    Ok great, let me know when you get home what result you got, just "stop" hyperion from HyperCon and then "start" and try change leds colors again and see if it works
     
  10. Arakon

    Arakon Member

    Messages:
    151
    Hardware:
    RPi1/Zero, RPi3, +Arduino
    Works for me.
     
  11. Draq

    Draq New Member

    Messages:
    17
    unbeliveble.. then I don't know what I am doing wrong.. :(

    it does clearly not work for me if I stop/start

    ws2812b leds you have?

    and rpi 3 b vi 2
     
  12. Arakon

    Arakon Member

    Messages:
    151
    Hardware:
    RPi1/Zero, RPi3, +Arduino
    That's some generic 144 LEDs strip I had gotten off aliexpress at some point, originally to put on my drones.. nothing special or specific.
    The Pi is a normal 3B (not plus).