1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

HyperCon HyperCon Ubuntu 14.04 not work :(

Discussion in 'Software Support' started by slaike, 15 May 2019.

  1. slaike

    slaike New Member

    Messages:
    5
    Hardware:
    32/64bit
    Hello! I am trying to launch Hyperion server on mini PC on ubuntu 13.04 according to the instructions here https://hyperion-project.org/wiki/HyperCon-Information
    I run through the terminal:
    --
    [email protected]:~$ java -jar ./HyperCon.jar
    Exception in thread "main" java.lang.UnsupportedClassVersionError: org/hyperion/hypercon/Main : Unsupported major.minor version 52.0
    at java.lang.ClassLoader.defineClass1(Native Method)
    at java.lang.ClassLoader.defineClass(ClassLoader.java:808)
    at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:142)
    at java.net.URLClassLoader.defineClass(URLClassLoader.java:443)
    at java.net.URLClassLoader.access$100(URLClassLoader.java:65)
    at java.net.URLClassLoader$1.run(URLClassLoader.java:355)
    at java.net.URLClassLoader$1.run(URLClassLoader.java:349)
    at java.security.AccessController.doPrivileged(Native Method)
    at java.net.URLClassLoader.findClass(URLClassLoader.java:348)
    at java.lang.ClassLoader.loadClass(ClassLoader.java:430)
    at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:323)
    at java.lang.ClassLoader.loadClass(ClassLoader.java:363)
    at sun.launcher.LauncherHelper.checkAndLoadMain(LauncherHelper.java:482)
    --
    What to do? How to start?
     
    Last edited: 16 May 2019
  2. TPmodding

    TPmodding Administrator Staff Member Administrator

    Messages:
    1,368
    Hardware:
    RPi1/Zero, RPi2, RPi3, +Arduino, +nodeMCU/ESP8266
    which java version do you have?
    java -version
     
  3. slaike

    slaike New Member

    Messages:
    5
    Hardware:
    32/64bit

    Attached Files:

    • java.jpg
      java.jpg
      File size:
      261.8 KB
      Views:
      28
    Last edited: 16 May 2019
  4. TPmodding

    TPmodding Administrator Staff Member Administrator

    Messages:
    1,368
    Hardware:
    RPi1/Zero, RPi2, RPi3, +Arduino, +nodeMCU/ESP8266
    Unsupported major.minor version 52.0

    and you have
    java version 1.7.0 51

    just update your java... :)
     
  5. slaike

    slaike New Member

    Messages:
    5
    Hardware:
    32/64bit
    I tried on another version of ubuntu 14.04 from Java 1.7.71
    There is exactly the same mistake! :(
     
  6. TPmodding

    TPmodding Administrator Staff Member Administrator

    Messages:
    1,368
    Hardware:
    RPi1/Zero, RPi2, RPi3, +Arduino, +nodeMCU/ESP8266
    from google:

    sudo apt-get install openjdk-8-jre

    sudo update-alternatives --config java
    and then select java8
     
  7. slaike

    slaike New Member

    Messages:
    5
    Hardware:
    32/64bit
    [email protected]:~$ lsb_release -a
    No LSB modules are available.
    Distributor ID: Ubuntu
    Description: Ubuntu 13.04
    Release: 13.04
    Codename: raring
    [email protected]:~$ sudo apt-get install openjdk-8-jre
    [sudo] password for userl:
    Reading package lists ... Done
    Building a dependency tree
    Reading status information ... Done
    E: Could not find package openjdk-8-jre
    [email protected]:~$ sudo update-alternatives --config java
    There is only one alternative in the java link group (providing /usr/bin/java): /usr/lib/jvm/java-7-openjdk-armhf/jre/bin/java
    There is nothing to adjust.

    :(((((
     
  8. TPmodding

    TPmodding Administrator Staff Member Administrator

    Messages:
    1,368
    Hardware:
    RPi1/Zero, RPi2, RPi3, +Arduino, +nodeMCU/ESP8266
    did you try google? how to update your java?

    whats wrong with you guys...
    own initiative = 0