1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

HyperCon hyperion NG installation

Discussion in 'Software Support' started by ben3218, 7 September 2019.

  1. ben3218

    ben3218 New Member

    Messages:
    17
    Hardware:
    RPi3
    Hello,
    I have raspberry 3 with ws 2801 led strip and was wondering, would it be possible to install hyperion NG on osmc or openelec operating system?
     
  2. TPmodding

    TPmodding Administrator Staff Member Administrator

    Messages:
    1,368
    Hardware:
    RPi1/Zero, RPi2, RPi3, +Arduino, +nodeMCU/ESP8266
    • Like Like x 1
  3. ben3218

    ben3218 New Member

    Messages:
    17
    Hardware:
    RPi3
    I have OSMC kodi 17.6 up and running.
    Then I used your Hyperion.NG kompilieren und installieren auf einem Raspberry Pi youtube tutorial (I skipped raspbian part).
    I did include
    sudo apt-get install rbp-userland-dev-osmc ( it seemed important since it mentioned OSMC)

    From the looks of it,hyperion ng got installed. I can access configuration menu of hyperion,select controller type etc. But the lights are not responding.
    When I putty hyperiond it says :
    [hyperiond LEDDEVICE] <ERROR> Failed to open device (/dev/spidev0.0). Error message: No such file or directory
    and it keeps repeating :
    "No carrier"
    "No carrier"
    "No carrier"

    Could it be I was on the right track? What else do I need to do?
     
  4. hopfinger

    hopfinger New Member

    Messages:
    6
    Hardware:
    RPi1/Zero, RPi2, RPi3
    Do you enabled the SPI Interface with raspi-config?
     
  5. ben3218

    ben3218 New Member

    Messages:
    17
    Hardware:
    RPi3
    No but, I have made several attempts.
    I used code:
    sudo raspi-config
    which works on raspbian,hoping it would let me in Raspberry Pi Configuration,but it didnt.
    I then tried with:
    # file in /boot/config.txt, need reboot
    and
    dtparam=spi=on
    which i fount at , those 2 lines went pretty much ignored.
    At last I turned on the tv and looked through OSMC setting but havent found anything related to SPI.
    That's when I ran out of ideas.
     
  6. Akriss

    Akriss Active Member

    Messages:
    505
    Hardware:
    RPi1/Zero, RPi2, RPi3, 32/64bit, +Arduino, +nodeMCU/ESP8266
    Osmc has a utility within the kodi interface to edit the "config.txt" file and add the needed line.
    I haven't ran a osmc Rpi in a wile, but if I remember correctly edited by hand it reverts back, need to use the utility.
    the utility was within the "Myosmc" tab, if I remember correctly.

    Hope its of help.
     
  7. ben3218

    ben3218 New Member

    Messages:
    17
    Hardware:
    RPi3
    Wonderful,I have found it! I have enabled SPI support but I get the same error on putty.
    However, there are more options,such as gpio_out_pin (17) and gpio_in_pin (18). My raspberry connects to led strip on pins 19 and 23. Is this something I should alter as well?
    And you were right about config.txt editor. It is there. But what is the needed line? The one that I mentioned in my previous reply?
     
  8. Akriss

    Akriss Active Member

    Messages:
    505
    Hardware:
    RPi1/Zero, RPi2, RPi3, 32/64bit, +Arduino, +nodeMCU/ESP8266
    Are for infrared in/out. Don't need to bother with it as you are not using a infrared receiver of transmitter.

    Correct,
    Code:
    dtparam=spi=on
    Hope its of help.

    Edit: this is a old thread with good tip to try:
    https://hyperion-project.org/threads/hyperion-not-working-with-osmc-kodi-16-1.370/
     
    Last edited: 9 September 2019
  9. ben3218

    ben3218 New Member

    Messages:
    17
    Hardware:
    RPi3
    It definitely is of help. Thank you very much.
    I did manage to write the code to the config.txt. So the lights are working now! Amazing:omg:! But only after I activate hyperion from my pc. Is there a way to have hyperion start automatically with OSMC?
    I did encounter an issue when playing movies with black bar. The tv would be flickering,switching randomly from raspberry's HDMI to "no signal" screen. Activating or deactivating blackbar detection from hyperion setting changes nothing. Selecting "zoom" as a view mode on kodi kind of fixes the issue,but then again limits to only watching zoomed in movies.

    Best regards,
     
  10. Akriss

    Akriss Active Member

    Messages:
    505
    Hardware:
    RPi1/Zero, RPi2, RPi3, 32/64bit, +Arduino, +nodeMCU/ESP8266
    Yes. It's requires a bit of work however.

    There is a default service file to start Hyperion.NG located here:
    https://github.com/hyperion-project/hyperion.ng/blob/master/bin/service/hyperion.systemd

    And to make use of that file I can only point you to some reading on how to use that file on a linux system.
    https://discourse.osmc.tv/t/how-to-create-a-service-on-osmc/21873

    https://www.devdungeon.com/content/creating-systemd-service-files

    Sorry I've not encountered that before. Is the RPI power supply >= 2.5 amp's ? if not maybe low current on the Rpi.

    Hope it of help.
     
    Last edited: 10 September 2019 at 22:12
    • Like Like x 1
  11. ben3218

    ben3218 New Member

    Messages:
    17
    Hardware:
    RPi3
    The power supply is 2.5 amps.
    Thanks again,I'll look in to those links.