1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

RPi + OpenELEC Hyperion on Raspberry pi Zero?

Discussion in 'Hardware Support' started by johnvid, 20 June 2016.

  1. johnvid

    johnvid New Member

    Messages:
    1
    Hardware:
    RPi1/Zero, RPi3, +Arduino
    Does anyone know if the hyperion for OpenElec works on a rpi zero?

    I've installed it and used the same pins I use on the rpi 3. It is installed and the Hyperion Apple app finds the zero and sends commands to it. But the light are not comming on.

    Does anyone know if I need to use different gpio pins on my Zero?

    Thanks in advance!
     
  2. penfold42

    penfold42 Moderator Developer

    Messages:
    742
    Hardware:
    RPi1/Zero, RPi2, RPi3, 32/64bit, +Arduino, +nodeMCU/ESP8266
    It should work - what is your led device type ?
     
  3. merlonius

    merlonius New Member

    Messages:
    1
    Hardware:
    RPi1/Zero, RPi3
    Do you use a Pi Zero 1.3 (the one with the camera connector) and the ws281x driver? I just had the problem that hyperion worked on a Zero 1.2 but refused to initialize the ws281x driver on the Zero 1.3 (using the same sd card). So I just compiled hyperion with the latest ws281x driver and everything worked fine (support for the Zero 1.3 was added to ws281x about 7 weeks ago).
     
  4. Brindosch

    Brindosch Administrator Administrator

    Messages:
    679
    Hardware:
    RPi1/Zero, RPi2, RPi3, +nodeMCU/ESP8266
  5. penfold42

    penfold42 Moderator Developer

    Messages:
    742
    Hardware:
    RPi1/Zero, RPi2, RPi3, 32/64bit, +Arduino, +nodeMCU/ESP8266
    Both rpi_281x submodules ?
    No - if it's not already in my fork, it's 5 lines of code to add it in
     
  6. Brindosch

    Brindosch Administrator Administrator

    Messages:
    679
    Hardware:
    RPi1/Zero, RPi2, RPi3, +nodeMCU/ESP8266
    1 No :)
    2 Yes
     
  7. K_Pi_Enthusiast

    K_Pi_Enthusiast New Member

    Messages:
    1
    Hardware:
    RPi1/Zero, RPi2, RPi3
    Merlonius, any chance you could walk us through how to compile hyperion with the latest ws281x driver?

    I have a Raspberry Pi Zero 1.3 (w/ camera attachment) and have been using HyperCon to install Hyperion onto the Pi. I installed this morning and the WS2801 LED's are not responding. Similar to Johnvid, I am able to connect to the Pi server via my phone app but the lights are not responding.

    Any help would be greatly appreciated!
     
  8. Icefluffy

    Icefluffy New Member

    Messages:
    2
    Hardware:
    RPi2
    Really HELP!

    I've been trying for 7 days now, It's KILLING me.....
    Google and the wiki are a mess!


    Please someone post how to:

    Get HYPERION working on:

    Raspberry Pi ZERO W running stretch in combination with theWS281x driver (not the WS2812spi => I get lights on but I need to be able to grab the colors from a jpg)
     
    Last edited: 18 November 2018