1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Other Inverted rgb code

Discussion in 'LED Devices Support' started by thouve, 29 April 2019.

  1. thouve

    thouve New Member

    Messages:
    8
    Hardware:
    RPi1/Zero, RPi3, 32/64bit, +Arduino, +PhilipsHue
    Hello everyone, new here, I registered because I have a problem that I do not see anywhere else.
    I have a led strip ws2812b connected to the gpio18 of my rpi.
    When I started my osmv, I found that the colors was strange because nothing matches.
    In digging with the rgb code, I notice that the data is "reversed", I explain:
    When I have red (255,0,0) I get cyan (0,255,255)
    When I have to have green (0,255,0) I get magenta (255,0,255)
    And for blue (0,0,255) I get yellow (255,255,0)
    Same for black (0,0,0) so I get white (255,255,255)
    Jaumerai then understand where it can come from. If some had the problem, how to solve it?
    Because I try to sell it to my wife for the tv in the living room but as it is I may not have a validation ^^
    Thank you in advance for your help, hoping to solve this problem.
     
  2. Arakon

    Arakon Member

    Messages:
    150
    Hardware:
    RPi1/Zero, RPi3, +Arduino
    The config also has a setting
    "colorOrder" : "rgb",

    You can freely change it around until it matches. For me, "grb" is correct.
     
  3. thouve

    thouve New Member

    Messages:
    8
    Hardware:
    RPi1/Zero, RPi3, 32/64bit, +Arduino, +PhilipsHue
    I say but not is my problem.
    My problem is really the code number.
    Example, the number code for white is 255,255,255 ( red green and blue are on)
    but the signal send is 0,0,0.
    I receive 0 for 255, 255 for 0, 12 for 243 etc

    ( sorry for my english i am french and don't speak english very well )
     
  4. thouve

    thouve New Member

    Messages:
    8
    Hardware:
    RPi1/Zero, RPi3, 32/64bit, +Arduino, +PhilipsHue
    I have test a new configuration.
    I change type : ws281x pwm for ws281x-SPI
    and the color it's ok, green is green, blue is blue, red is red,......
    but don't work with movie.
    In the menu, the leds is white and when the movie start, the leds remain white :/
     
  5. TPmodding

    TPmodding Administrator Staff Member Administrator

    Messages:
    1,303
    Hardware:
    RPi1/Zero, RPi2, RPi3, +Arduino, +nodeMCU/ESP8266
    "invert": 1

    try this at your config