1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

[NICHT GELÖST] what(): VIDIOC_DQBUF ERROR 19, No such device

Discussion in 'German Talk' started by Delta3456, 13 May 2016.

  1. Delta3456

    Delta3456 New Member

    Messages:
    3
    Hardware:
    RPi2
    hey ich habe ein Problem mit meinem hyperion, ich hoffe ihr könnt mir helfen da es immer wieder abstürtzt;
    Die Meldung kommt immer ca. nach 2-5 Minuten.

    ssh in: INFO: Hyperion started and initialised
    ssh in: INFO: Json server created and started on port 19444
    ssh in: INFO: Proto server created and started on port 19445
    ssh in: V4L2GRABBER INFO: width=720 height=480
    ssh in: V4L2GRABBER INFO: pixel format=YUYV
    ssh in: BLACKBORDER INFO: threshold set to 0.15 (39)
    ssh in: BLACKBORDER INFO: mode:default
    ssh in: V4L2GRABBER INFO: signal threshold set to: {25,25,25}
    ssh in: V4L2GRABBER INFO: started
    ssh in: INFO: V4L2 grabber created and started
    ssh in: BORDER SWITCH REQUIRED!!
    ssh in: CURRENT BORDER TYPE: unknown=0 hor.size=0 vert.size=0
    ssh in: BORDER SWITCH REQUIRED!!
    ssh in: CURRENT BORDER TYPE: unknown=0 hor.size=0 vert.size=2
    ssh in: terminate called after throwing an instance of 'std::runtime_error'
    ssh in: what(): VIDIOC_DQBUF ERROR 19, No such device
    ssh in: Aborted
     
  2. Brindosch

    Brindosch Active Member

    Messages:
    678
    Hardware:
    RPi1/Zero, RPi2, RPi3, +nodeMCU/ESP8266
    Hallo Delta3456,
    dieser Fehler meldet, dass dein V4L2 Grabber sich einfach abmeldet. Benutzt du auch einen HDMI zu CVBS Konverter?
     
  3. TPmodding

    TPmodding Administrator Staff Member Administrator

    Messages:
    1,303
    Hardware:
    RPi1/Zero, RPi2, RPi3, +Arduino, +nodeMCU/ESP8266
    Es könnte an der Stromversorgung des USB grabbers liegen...

    Kannst du bitte mehr Infos zu deiner Hardware und zu deinem system liefern damit wir es einschränken können. Vielen Dank
     
  4. Delta3456

    Delta3456 New Member

    Messages:
    3
    Hardware:
    RPi2
  5. TPmodding

    TPmodding Administrator Staff Member Administrator

    Messages:
    1,303
    Hardware:
    RPi1/Zero, RPi2, RPi3, +Arduino, +nodeMCU/ESP8266
    d.h. Dein rpi wird mit einem 1A Netzteil versorgt wo der USB grabber direkt an einem USB Port des pis hängt, richtig?
     
  6. Delta3456

    Delta3456 New Member

    Messages:
    3
    Hardware:
    RPi2
    Mein pi wird durch ein 2A Netzteil versorgt und ja der USB grabber hängt direkt an einem USB Port des pis.
     
  7. Brindosch

    Brindosch Active Member

    Messages:
    678
    Hardware:
    RPi1/Zero, RPi2, RPi3, +nodeMCU/ESP8266
    @Delta3456
    Könntest mit einem anderen usb kabel als Stromversorgung nochmal testen?
    Eventuell hat auch der grabber eine Macke