1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

SOLVED PhilipsHue + v4l2 grabber + low light scenes - Red/Blue light output

Discussion in 'Software Support' started by bnealon, 19 March 2019.

  1. bnealon

    bnealon New Member

    Messages:
    14
    Hardware:
    +PhilipsHue
    Hi,
    I'm running Hyperion on a Raspberry Pi 3 B+ running raspbian-stretch with 4 philips hue bulbs in my living room (one in each corner of the room). I don't have any LED's around the screen at the moment, and have been trying to configure Hyperion to produce a nice subtle ambient affect, without flickering and sporadic changes in colour.

    I'm fairly happy with my config, and have had to introduce smoothing (suggested workaround) for the open issue HERE.

    The only issue i continue to have is during low light scenes, where the lights are getting close to turning off - the lights get sent either a bright blue or red colour (colour depends on the nature of the video input). I spent a while testing my setup with Game of Thrones last night, re-playing certain tricky scenes to fine tune my config. Whenever there is a low light scene with candlelight, or yellow light/skin tone the hue bulbs will glow red. I managed to capture a screenshot from the USB videograbber and the video signal is perfect, has no visual red present and i would expect the lights to turn more yellow than red here:

    Screenshot 2019-03-19 08.56.43.png

    Alternatively, any of the GOT scenes that have snow in tend to turn to blue before turning off.

    Is this a known issue, or is there a workaround?

    I spent a while experimenting with both the grabber-v4l2.red/green/bluethreshold, along with the blackborderdetector.threshold values. I've also followed the blackborderdetector.threshold tutorial by using a colour picker on the screengrab to get the correct value, which gave me ~8% and still did not fully correct the issue.

    Cheers

    EDIT:
     
    Last edited: 19 March 2019
  2. bnealon

    bnealon New Member

    Messages:
    14
    Hardware:
    +PhilipsHue
    Just a quick update, this issue does not exist on the latest compiled version of Hyperion.ng. Apart from the outstanding issue of switchOffOnBlack=true not working, the colours and functionality .ng provides is a vast improvement over the current version of Hyperion.
    I gather than the issue i was seeing could be fixed with calibration, however with .ng i do not need to calibrate the colours of the bulbs as they work perfectly.
     
    • Like Like x 1
  3. TPmodding

    TPmodding Administrator Staff Member Administrator

    Messages:
    1,303
    Hardware:
    RPi1/Zero, RPi2, RPi3, +Arduino, +nodeMCU/ESP8266
    Good to hear! Thanks :)
     
    • Like Like x 1
  4. bnealon

    bnealon New Member

    Messages:
    14
    Hardware:
    +PhilipsHue
    Just for confirmation now that this is resolved, I'm using the same hardware and configuration values for my v4l2 configuration, therefore the sizeDecimation value of 8 is perfectly fine, as since the code internally doesnt look to be blurring on downsample, just removing some of the pixels - everything seems to work just as well with a value of 8 OR 2, and therefore the overall colours from the grabber are unadjusted.