1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Tuning Colors of LED's for screen captuure

Discussion in 'Hyperion General' started by Jeff Moore, 18 June 2019.

  1. Jeff Moore

    Jeff Moore New Member

    Messages:
    2
    Hardware:
    RPi3
    Hi Guys, I've recently built a ambilight setup for passthrough using the following

    - Raspberry Pi 3 B+
    - OSMC as operating System
    - Latest version of hyperion and hyperion config tool
    - WS2801 LED's ( about 3 M )
    - HDMI splitter
    - HDMI to AV
    - USB Video Grabber (Fuschia ChipSet UTV 007)

    I did have to reduce the video settings on one device ( Firetv cube ) from 4K down to 1080p @ 60hz to get the screen grabbing to work....otherwise I just saw rainbow effect behind screen.

    Everything seems to be working good but the colors seem to be quite muted and dull. It seemed to be ok/better with the colors when using the internal grabber and Kodi checker enabled.

    Using static images on screen to adjust the colors seemed to work great but the range of the colors when playing a video through internal grabber or setup for passthrough using the USB grabber is not great.

    I can share my hyperion config file later this afternoon when I get home, but perhaps someone has some suggestions as to what values to change to get the best color from the led's?
     
  2. DJmvt

    DJmvt New Member

    Messages:
    1
    Hardware:
    RPi1/Zero, +Arduino
    Hi Jeff,

    Setting the colors is quite some work, at least that's my experience. With kodi internal it was alright straight after installing but since I've been using the external grabber it took me a while to set things up the way I wanted.

    I've uploaded my config so maybe you can get some examples from that. Only issue I'm having at the moment is that when using hyperion as "normal lightsource" there's a flash sometimes coming from the external grabber trying to take over. I've just now changed the frame grabber priority to 900 (had it on 800) to see if that helps.

    To clarify: I'm using hyperion as ambilight with TV pictures but I also use it as normal (fixed) lightsource by sending commands with Pimatic. So when the TV is not in use it will automatically switch to fixed backlight mode. Hope that's understandable, it's a rather complex system with 2 Raspberry pi's and a lot more hardware and software haha.
     

    Attached Files:

  3. Jeff Moore

    Jeff Moore New Member

    Messages:
    2
    Hardware:
    RPi3

    Thanks so much @ DJmvt!! Everything seems to be working really well with mine for the most part, what I've encountered so far is that the colors only really seem to be muted when the source hdmi signal is coming from a FireTV Cube. Cable box works great and hdmi out from rpi ( osmc/kodi ) works great with the grabber (just as well as internal grabber ).

    I'm wondering if the firetv display signal needs to be adjusted or perhaps a different hdmi cable?

    Lastly, I was trying to adjust the white levels yesterday and i noticed the color was more yellow further down the line ( left side of TV, so I read that I can supply power at the end of the strips as well as the beginning and that maybe power might be an issue for the strips, although the strips are reading 5V throughout the whole strip. ( my setup has 107 leds, and from what I read that apparently there are/were issues with WS2801 when lighting up more than 100 leds).

    I was confused when adjusting whitelevel using Hyperion Remote App for iOS and the valid values where between 0 and 1 but the valid values to use from the HyperCon config tool are between 0 and 255??

    I will take a look at your config and see if any of your settings can help me....thanks so much!!

    I didn't realize you could use prismatik along with the ambilight/rpi setup. I'd love to read about what you are doing with Prismatik. Sounds really cool!