1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

HyperCon Use Hyperion as forwarder only without local LED device

Discussion in 'Software Support' started by B03S, 16 February 2019.

  1. B03S

    B03S New Member

    Messages:
    4
    Hi,

    I've switched to a TV with built-in ambilight so I don't have a LED device attached to my mediabox anymore.
    (Minix UH-9 running LibreElec)

    I do however have two lamps with Pi's and ws2801 LED strips which used to mimic the left and right side of the screen using the forwarder function in Hyperion.

    I would like to continue using Hyperion but as forwarder only, is this possible?

    My former device config was

    -------------------
    "device" :
    {
    "name" : "Pi1",
    "type" : "ws2801",
    "output" : "/dev/spidev0.0",
    "rate" : 250000,
    "colorOrder" : "bgr"
    },
    -------------------

    I've tried replacing type with test or none and redirecting output to /dev/null.
    Is their some sort of dummy device or trick to start Hyperion without a LED device?
    Currently it fails with a LEDDEVICE ERROR: Unknown/Unimplemented device ws2801 etc.
     
  2. B03S

    B03S New Member

    Messages:
    4
  3. B03S

    B03S New Member

    Messages:
    4
    Well Hyperion starts on the Minix and forwards to both PI's, tested with the Hyperion app on my phone.
    But the videograbber doesn't seem to work, when playing video the leds don't light up.
     
  4. B03S

    B03S New Member

    Messages:
    4
    With hardware acceleration turned off it works..but that's needed for 4K.