1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

SOLVED Violet light on black edges

Discussion in 'Software Support' started by Toudi, 4 May 2016.

  1. Toudi

    Toudi New Member

    Messages:
    1
    Hardware:
    RPi2
    Hello,

    I've just added ambilight to my Kodi (Open Elec, Raspberry 2). It works great, except that i have violet light while border is black.
    How can i change this?

    Bets,
    Martin
     
  2. tulipo

    tulipo New Member

    Messages:
    2
    Hardware:
    RPi1/Zero
    Download the hyperion app for android. Play a movie with a black scene and put it on pause. After that open the app and tap on color transforms default. On that screen make some little adjustment until the led are close enough the image on tv. Make also sure that after that adjustement all the other colors are fine.
    Take note of that value you change and put it on hypercon.jar to create a proper config file. Change you made with the app is not saved after a restart.
     
    • Like Like x 1
  3. Brindosch

    Brindosch Active Member

    Messages:
    678
    Hardware:
    RPi1/Zero, RPi2, RPi3, +nodeMCU/ESP8266
    Hello Toudi,
    please don´t use any smartphone app for now. Most values are deprecated and replaced. New apps are coming soon.
    Please calibrate your colors with the advice of the following wiki article:
    Color Calibration
     
    • Like Like x 1
  4. tulipo

    tulipo New Member

    Messages:
    2
    Hardware:
    RPi1/Zero
    Perfect... Good to know for me too...
     
  5. Zac Morris

    Zac Morris New Member

    Messages:
    16
    Hardware:
    RPi1/Zero, RPi2, RPi3, +Arduino
    Yeah, I mucked around with a similar issue for several days, and then I read the configuration guide on the wiki, step-by-step. not skipping around like I had been doing, and it's now working perfectly.

    I had jumped right into Color Correction, because at first I was having a lot of green. I was guessing my LEDs might just be green heavy so I started mucking around trying to do color correction; the real issue was that my video grabber was generating a lot of green lines in its captures. I needed to change the Frame and Size decimations to remove the green lines from the captures. The following settings worked best for me:

    Code:
    hyperion-v4l2 --width 720 --height 480 --screenshot --frame-decimator 1 --size-decimator 4 --crop-left 5 --crop-right 15 --crop-top 2 --crop-bottom 1
    By going with a lower frame-decimator I was getting no green lines, but a small amount of lag caused by the extra data; I was able to tweak that away with smoothing.
     
    • Like Like x 1