1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

SOLVED Error while reading data from host

Discussion in 'Software Support' started by bastianum, 20 October 2018.

  1. bastianum

    bastianum New Member

    See above
  2. Akriss

    Akriss Active Member

    RPi1/Zero, RPi2, RPi3, 32/64bit, +Arduino, +nodeMCU/ESP8266
    Make sure the edit are still in:
  3. fedorin

    fedorin New Member

    I have exact same issue with exact same configuration!
    Got my led strip lit only with SPI mode config (thank you, @Akriss)But now any of leds that shouldn't be active flicker with random color constantly. It seems like some trash goes to GPIO 10. It stops (and stucks on the last leds' status) only when i stop Hyperion service.
    I use latest OSMC, latest Hyperion, added spidev.bufsiz=32768 to the end of /boot/cmdline.txt
    Also, can't undertand why non-spi mode doesn't work (literally have been trying for 4 days!)

    Any help would be appreciated.
  4. Akriss

    Akriss Active Member

    RPi1/Zero, RPi2, RPi3, 32/64bit, +Arduino, +nodeMCU/ESP8266
    It's possible that the 3.3v signal sent from the Rpi's SPI bus is falling short and causing the trouble. The led's expect the data to be closer to 5v. A 3.3v to 5v level shifter/line buffer could be the fix.

    This should help the understanding. (important-warning-about-dma-channels). Hyperion uses this library to drive the WS2812 leds. So the same limitations apply.

    Hope it helps.
    • Like Like x 1
  5. fedorin

    fedorin New Member

    Thank you very much for quick and meaningful response!
    In my case the flickering were eliminated by adjusting output voltage of PSU that powers LED strip: 5.02v wasn't enough, i set it to 5.12v and it worked like a charm. I would never even think of such a way but an adjustment screw got on my eyes and having no other ideas, I just turned it a little.
    Before that i tried to use level-shifter which worked decreasing random blinking. Also, i used 300 Ohm resistor for data line wire - worked as well, even better than level-shifter.but still had a lot troubles on leds with low brightness

    If anyone needs, i can record a video where i'd be turning 'screw' with voltmeter applied to contacts. Just as a proof.
    Last edited: 15 December 2018
  6. daVid0n

    daVid0n New Member

    RPi1/Zero, RPi3, +Arduino, +PhilipsHue, +nodeMCU/ESP8266
    hey there,
    I am trying everything I read here since three days now, but nothing works for me.

    I have the same "Error while reading data from host" when sending anything over hyperion-remote, the thing I just can't understand at all is, that if I keep waiting for about 40 minutes, this problem gets suddenly resolved and then I have direct access to the leds - once I reboot the Pi, same issue again.. this buggy behavior drives me mad.

    My setup is:
    - rPi3B
    - WS2812B (testing stripe with just 5 LEDs atm, original setup would be 260 LEDs) -> DATA connected to GPIO18/pin12, 5V to rPi, GND to rPi
    - raspbian stretch lite - release Nov. 18

    in my config I have put the following:

    "device" :
    "name" : "amPiLight",
    "type" : "ws281x",
    "gpio" : 18,
    "freq" : 800000,
    "pwmchannel" : 0,
    "dmanum" : 10,
    "leds" : 260,
    "colorOrder" : "grb"

    From previous issues I "learned" about the dmanum, if I remove it, the whole system may freeze sooner or later.
    I am doing fresh reinstalls of the whole rPi SD-card almost 10 times per day, always also doing the recommended entries:

    --> spidev.bufsiz=32768 at the end of /boot/cmdline.txt
    --> core_freq=250 at the end of /boot/config.txt
    before entering the SD-card into the rPi for the first time.

    I also tried out to change the driver to WS281x-SPI as recommended, but then hyperion won't start anymore and directly gives another " hyperion.service: Failed with result 'exit-code'. "

    Further I am not able to run hyperion with the standard WS281x driver, whenever V4L2-grabber is enabled, but I want to use my PS3-cam to grab the image, which works perfectly, when grabbing manually via console, but hyperion also gives a failed with result 'exit-code', as soon as it is enabled in the config.

    I know, these were more problems than related to this thread, but maybe someone sees something I just don't.. trying to get hyperion running since one year now, but I am finally about to give up - so please could you help me out?
    Thank you very much in advance!
    Last edited: 30 December 2018