1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

RPi + OSMC Error while reading data from host

Discussion in 'Hardware Support' started by laura20400, 25 June 2019.

  1. laura20400

    laura20400 New Member

    Messages:
    6
    Hardware:
    RPi3
    Hello, I have a strip of leds WS2811 connected to the raspberry pi 3b +. In the first case I connect two cables to the power supply and then connect the other three cables to the gnd pin, the clk pin and the data pin. Active spi in the file config.txt and I put the core_freq = 250. I do the installation step by step correctly and in no time it gives error, finally with hypercon I export the file hypercon.config.json and I put it in /etc/hyperion.The thing is that it starts correctly (does not give error), but it does not makes the rainbow effect. If I try to change the color sudece an error:
    [email protected]:~$ hyperion-remote --priority 50 --color red --duration 5000
    hyperion-remote:
    version : V1.03.4 (brindosch-c750c41/dc6a602-1522918225
    build time: Apr 5 2018 01:57:05
    Connected to localhost:19444
    Set color to 255 0 0
    Error while reading data from host
     
  2. TPmodding

    TPmodding Administrator Staff Member Administrator

    Messages:
    1,840
    Hardware:
    RPi1/Zero, RPi2, RPi3, +Arduino, +nodeMCU/ESP8266
    you sure it is ws2811? cause they dont have a clock pin?

    edit: and please dont ask the same question in different threads...otherwise i lose the overview
     
  3. Berndlaran

    Berndlaran New Member

    Messages:
    1
    Hardware:
    RPi1/Zero, RPi3
    Hi!

    I've got the same problem - but I'm using a 2812b LED Strip. The ws28xx Package is installed and the Demo functions are working - but when I install Hyperion i also get the same Error (Error while reading data from host) - any ideas?

    Thanx!