1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Farbkalibrierung - Farben stimmen überhaupt nicht!!!

Discussion in 'German Talk' started by David Sommer, 16 November 2019.

Tags:
  1. David Sommer

    David Sommer New Member

    Messages:
    24
    Hardware:
    RPi3
    Moin moin,

    ich bin am Verzweifeln. LEDs sind verlötet und ich kann mich mit Hyperion verbinden. Alle Geräte sind ebenfalls zusammengesteckt.

    Ich versuche jetzt schon seit Längerem die Farben einzustellen und bekomme es nicht hin. Die Farben stimmen überhaupt nicht mit dem Fernsehbild überein.
    Bitte um Hilfe. Was kann ich tun???

    Lieben Gruß
    David Sommer
     
  2. Cosmicbase

    Cosmicbase Member

    Messages:
    315
    Hardware:
    RPi3, +Arduino
    Erzähl mir mal was du für ein System hast.
    Hyperion.ng oder das alte Hyperion?
    Welche LEDs und wie schaut deine Config aus?
     
  3. David Sommer

    David Sommer New Member

    Messages:
    24
    Hardware:
    RPi3
    Ob es das alte oder das neue Hyperion ist, weiß ich nicht. In dem Hyperion Programm steht, dass es von 2017 ist.
    Meine LEDs sind die APA102.
     

    Attached Files:

  4. Cosmicbase

    Cosmicbase Member

    Messages:
    315
    Hardware:
    RPi3, +Arduino
    Wie schauen die Farben aus?
    Ist grün auch grün.
    Rot ist rot.
    Und blau auch blau.

    Also nix vertauscht?
     
    Last edited: 16 November 2019
  5. Cosmicbase

    Cosmicbase Member

    Messages:
    315
    Hardware:
    RPi3, +Arduino
    Lies dir mal die HowTo durch. Die kannst auch auf deutsch umstellen.
    Wenn fragen darüber hinaus dann Liebend gerne.
     
  6. David Sommer

    David Sommer New Member

    Messages:
    24
    Hardware:
    RPi3
    Genau das ist das Problem. Ich kriege es nicht hin, dass die Farben übereinstimmen. Die LEDs spucken eine ganz andere Farbe aus, als es auf dem TV angezeigt wird.
     
  7. David Sommer

    David Sommer New Member

    Messages:
    24
    Hardware:
    RPi3
    Egal welchen Wert ich einstelle. Es passt nicht. Hast du eine Idee dazu?
     
  8. Cosmicbase

    Cosmicbase Member

    Messages:
    315
    Hardware:
    RPi3, +Arduino
    1. Was für Farbe zeigen die LEDs wenn TV Bild grün.
    2. Was für eine Farbe zeigen die LEDs wenn TV Bild rot.
    3. Was für eine Farbe zeigen die LEDs wenn das TV Bild blau ist.
    Bitte beantworte jede Frage.
    Wir werden Stück für Stück deine Config durch gehen.
     
  9. Cosmicbase

    Cosmicbase Member

    Messages:
    315
    Hardware:
    RPi3, +Arduino
    Du hast APA102 LED Stripe mit 130 Leds?
    Probier mal BGR zu tauschen in RGB oder BRG oder RBG oder GBR etc.
     
  10. Cosmicbase

    Cosmicbase Member

    Messages:
    315
    Hardware:
    RPi3, +Arduino
    Wichtig ist auch die Reihenfolge :
    Ob der LED Strip von vorne betrachtet im Uhrzeigersinn (Clockwiese) oder gegen Uhrzeigersinn (Counterwise) installiert ist.
     
  11. David Sommer

    David Sommer New Member

    Messages:
    24
    Hardware:
    RPi3
    Auf die Reihenfolge habe ich bei der Installation geachtet. Die anderen Infos kommen gleich
     
  12. David Sommer

    David Sommer New Member

    Messages:
    24
    Hardware:
    RPi3
    BGR habe ich zumindest mal auf RGB gestellt. Kann gleich nochmal die anderen versuchen
     
  13. David Sommer

    David Sommer New Member

    Messages:
    24
    Hardware:
    RPi3
    TV Bild grün --> LEDs weiß (komischerweise oben ein warmes weiß und unten ein kaltes)
    TV Bild rot --> LEDs türkis blau
    TV Bild blau --> ähnlich wie bei grün. Weiß, oben etwas wärmeres weiß
     
  14. Cosmicbase

    Cosmicbase Member

    Messages:
    315
    Hardware:
    RPi3, +Arduino
    Bitte alle Farben versuchen, RBG und...
    Es muss auf jeden Fall am Anfang des Strips und am Ende eine 5V + vom Netzteil kommen. Sonst ist von vorne bis hinten Spannunsabfall.
     
  15. Cosmicbase

    Cosmicbase Member

    Messages:
    315
    Hardware:
    RPi3, +Arduino
    Schaue auf jeden Fall mal das die Grundfarben stimmen.
     
  16. David Sommer

    David Sommer New Member

    Messages:
    24
    Hardware:
    RPi3
    Also wenn ich beide Seiten mit Strom verbunden habe, gab es Disco. Als ich nur die eine Seite verbunden hab, war es gut
     
  17. David Sommer

    David Sommer New Member

    Messages:
    24
    Hardware:
    RPi3
    Unter BRG habe ich es gerade zumindest hinbekommen, dass blau auch blau ist. Allerdings stimmen die anderen Farben noch nicht.
     
    Last edited: 17 November 2019
  18. David Sommer

    David Sommer New Member

    Messages:
    24
    Hardware:
    RPi3
    Ich kann mit dem Temperatur Regler jede Farbe einzeln gut aussehen lassen. Die anderen Farben passen dann aber leider nicht.
     
    Last edited: 17 November 2019
  19. Cosmicbase

    Cosmicbase Member

    Messages:
    315
    Hardware:
    RPi3, +Arduino
    Hmm hab so ein Problem noch nicht gehabt.
    Es gibt nicht nur BRG sondern auch BGR. Vielleicht mal so probieren.
    Wenn nicht dann nochmal neu aufsetzen.
    Ich bin auf Hyperion.ng umgestiegen.
    Das läuft über OSMC oder Raspbian echt gut und du kannst alles über eine WebGui via IP Adresse einstellen.
     
  20. David Sommer

    David Sommer New Member

    Messages:
    24
    Hardware:
    RPi3
    Gibt es für Hyperion.ng irgendwo eine deutsche Anleitung, um das einzurichten?
    Also wie ich Hyperion.ng auf dem Raspberry pi installiert kriege.