1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

SOLVED Flickering when Led going in low brigthness

Discussion in 'Software Support' started by flapman, 2 January 2021.

Tags:
  1. flapman

    flapman New Member

    Messages:
    14
    Hardware:
    RPi3
    Whole set up with APA102 stripes and Hyperion NG Alpha 9 working perfectly with internal and external grabber in regadrs of changing colors. But as I want it to be perfect, I have a issue which I couldn´t find in the forum. When a dark scence comes up or the color is not in full brigthness (I would guess below 20-30% brightness), the led starts flickering but not hard flickering it like on off and it is happening with same the color. So it is not a black problem. This applys only to the external grabber. Which value need to be changed to stop that?
    GND is connected to PI and Stripe.
    This kind of flickering wasn´t visible with the old Hyperion. So guessing it is a Software option
    I am asking, before I start to buy a new powersupply and ferrite filter.
     
    Last edited: 3 January 2021
  2. clempat

    clempat New Member

    Messages:
    2
    Hardware:
    RPi3
    I think I am getting the same issue. I did not find the right configuration. I think the issue is around "Color Calibration" in "Image Processing". For example I put "Backlight threshold" to "40%" this flickering effect disappear. But the light is on instead of black.
     
  3. clempat

    clempat New Member

    Messages:
    2
    Hardware:
    RPi3
    Actually right now I put all Gamma to 2.5 and deleted the the previous "Backlight threshold". I have now no flickering and the leds are black when black background.
     
  4. flapman

    flapman New Member

    Messages:
    14
    Hardware:
    RPi3
    Yes for black I did the same, because I had the same what you have said. But I have the flickering with the colored LED´s on low brigthness. But I think it is the Hardware. When I look into the Live View, I can see this flickering as well. I am thinking about to buy new hardware, as mine is Hdmi splitter and analog stick.
     
  5. Alpha7

    Alpha7 New Member

    Messages:
    12
    Hardware:
    RPi1/Zero
    How many total LEDs do you have and what power supply?

    I have the APA102 LED's and I've never experienced flickering. What baudrate and refreshrate do you have set on the LED Controller section?
     
  6. flapman

    flapman New Member

    Messages:
    14
    Hardware:
    RPi3
    It was the Grabber and Converter, don´t know which one has make the problems. Bought yesterday a new HDMI2USB Grabber, everything now works fine.