1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Fragen zum Ambilight

Discussion in 'German Talk' started by fuxi, 12 November 2020.

  1. fuxi

    fuxi Member

    Messages:
    43
    Hardware:
    RPi1/Zero, RPi3, 32/64bit, +Arduino, +PhilipsHue, +nodeMCU/ESP8266
    Hallo,

    ich hatte bis vor ein paar Monaten Hyperion auf einem Raspi 3b laufen und meinen Bildschirm mit 64 WS2801 Leds bestückt. Als Grabber hatte ich die analog-zu-digital Variante mit einem USB-Videograbber.
    Es funktionierte soweit auch alles allerdings hatte das Ambilight eine Reaktionszeit von fast einer Sekunde was wirklich sehr schlecht ist. Ich habe mir zwischenzeitlich einen Raspi 4 mit 8 GB bersorgt und das ganze upgegradet und den analogen Videograbber mit einem digitalen ersetzt: https://www.amazon.de/gp/product/B08GR1LWT2/ref=ppx_yo_dt_b_asin_title_o01_s00?ie=UTF8&psc=1
    Dies funktioniert auch, allerdings ohne erhofften Geschwindigkeitsboost - die Reaktionszeit ist nachwievor gleich schlecht. Bei einem starken Farbwechsel hinkt Hyperion mit knapp einer Sekunde hinterher und es macht schlichtweg keinen Spaß.

    Daher meine Fragen:
    • ist die Performance mit Hyperion generell so schlecht bzw. wie kann sie verbessert werden?
      Liegt es evtl. an den alten WS2801? Die sollten doch eigentlich schnell genug sein ..
      Kann man anstatt dem Raspi auch den PC berechnen lassen? Wäre das schneller?
    • Ein Problem: ich wollte WLED mit dazuhängen welches bereits konfiguriert ist und mit einem Wemos D1 Mini läuft und habe es dementsprechend in Hyperion eingetragen (IP + Port) - nach dem Speichern hat es aber irgendwas zerschossen und das Hyperion Webinterface ist seither nicht mehr aufrufbar - ERR_CONNECTION_REFUSED.
      Woran könnte das liegen?
    Ich habe noch eine Arduino-Ambilight-Variante mit Ambibox welche nur am PC läuft, die aber extremst gute Echtzeitperformance bietet, daher ist mir nicht ganz verständlich warum es am Raspberry so schlecht läuft.
    Hier gibt es nur ein sehr seltsames Problem: der Grabber reagiert auf bestimmte Videoinhalte im Browser nicht - er "sieht" quasi nichts - das ist bei Amazon Prime Video und Unitmedia im Browser der Fall - das Ambilight bleibt einfach aus .. weiß jemand woran das liegt? Ist das evt. eine Art Windows-interner Kopierschutz?

    Danke + Grüße
     
  2. pclin

    pclin Active Member

    Messages:
    634
    Hardware:
    +nodeMCU/ESP8266
    Zur Verzögerung:
    Auflösung am Grabber verringern, und für bessere Performance HyperHDR verwenden.

    Wenn du den Loop Out verwendest schränkst du deine Anlage ein, max. Auflösung 1080p 30Hz, kein HDR und HDCP 2.2.

    gruß pclin
     
    Last edited: 12 November 2020
  3. fuxi

    fuxi Member

    Messages:
    43
    Hardware:
    RPi1/Zero, RPi3, 32/64bit, +Arduino, +PhilipsHue, +nodeMCU/ESP8266
    Danke für die Info - ist HyperHDR offiziell von Hyperion oder nur eine Art Mod? Ich habe es installiert und es sieht soweit super aus - beim ersten Test mit der Live Preview wirkte es synchron mit dem Testvideo. Muß es heute Abend im Dunkeln testen :)

    Noch eine Frage: HyperHDR lässt sich ja auch am Rechner installieren - würde es irgendwie gehen, damit den Loop Out auszulesen und damit die LEDs zu steuern? Irgendwie fehlt mir hier noch die logische Connection vom Rechner zu den LEDs .. :)
     
  4. pclin

    pclin Active Member

    Messages:
    634
    Hardware:
    +nodeMCU/ESP8266
    HyperHDR ist ein Fork von @Awawa und basiert auf dem aktuellen hyperion-ng.

    Vom Rechner zu den LED's kannst du z.B. ESP8266 mit WLED verwenden.

    gruß pclin