1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

FIXED Frame grabber video format standart is NTSC?

Discussion in 'Bug Reports' started by S3cret, 2 May 2016.

  1. S3cret

    S3cret New Member

    Messages:
    4
    Hardware:
    RPi1/Zero
    Hello,

    I was setting up Hyperion today. Big thanks for the nice usage using HyperCon.

    When it came to getting images via v4l2 grabber I notifced that a huge bottom part in the image was missing. All grabber settings were default (video format = no change). When I changed the video format to PAL the image was complete. Changed back to no change and the image was still good. Changed to NTSC and part was missing. Changed back to no change and part again was missing.

    It appears to me that no change always gets the last setting or NTSC by default? This is confusing because I would assume that it gets correct setting automatically.
    So I am not sure if this is a bug or wanted, in case of the second I would suggest renaming it to something that this becomes clear.

    Thank you for all the work you put into this project. It's simply awesome!

    Greetz, S3cret
     
  2. Brindosch

    Brindosch Active Member

    Messages:
    658
    Hardware:
    RPi1/Zero, RPi2, RPi3, +nodeMCU/ESP8266
    I could confirm this behaviour
    Seams to be a "bug" at hyperion-v4l2
    if you change at this moment back to PAL and use it, and then try again with no change. It should be right again?
     
  3. S3cret

    S3cret New Member

    Messages:
    4
    Hardware:
    RPi1/Zero
    Yes, whenever I switch from PAL to 'no change' it works, but changing from NTSC to 'no change' does not.
     
  4. TPmodding

    TPmodding Administrator Staff Member Administrator

    Messages:
    1,886
    Hardware:
    RPi1/Zero, RPi2, RPi3, +Arduino, +nodeMCU/ESP8266
    if you switch for example to PAL, then the grabber works with pal...and when you choose "no change" then it changes nothing and pal will stay...same with ntsc..."no change" uses the last option that is selected :)
     
  5. S3cret

    S3cret New Member

    Messages:
    4
    Hardware:
    RPi1/Zero
    Well, in that case I may ask what this setting is for. Just put PAL and NTSC into the list and its fine. It is totally confusing this way and by default it was NTSC but said it 'no change'.
     
    • Like Like x 1
  6. Brindosch

    Brindosch Active Member

    Messages:
    658
    Hardware:
    RPi1/Zero, RPi2, RPi3, +nodeMCU/ESP8266
    So, the answer from tvdzwan:
    no-change' implies that hyperion will open the v4l device as it is currently configured. This option allows the user to configure it with the controls of v4l and then leave it as is.

    addition from Rick164:
    You can set it manually via v4l commandline and it will remember that change but it will be a rare user case.

    So we will remove it from the drop-down :)
     
    Last edited: 7 May 2016
  7. S3cret

    S3cret New Member

    Messages:
    4
    Hardware:
    RPi1/Zero
    Ah ok, so it was just confusing but now it makes sense.

    Thanks for your effort.