1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

RPi + LibreELEC [HowTo] Install Hyperion.ng on LibreELEC x86_64/RPi (inoffiziell/unofficially)

Discussion in 'Software Support' started by Paulchen-Panther, 19 March 2020.

  1. Zoltán Varga

    Zoltán Varga Member

    Messages:
    37
    Hardware:
    RPi1/Zero, RPi3, 32/64bit, +nodeMCU/ESP8266
    for me it changes to
    Hyperion status: Off
    so i have to quit kodi like this
    systemctl stop kodi && systemctl restart hyperion.service

    and im on alpha6 not 7 as you are, bc 7 is just not ok for me.

    --------------------

    systemctl disable kodi seems an easy solution :) but kodi starts anyway.

    ------------------

    systemctl mask kodi, wont start kodi, and hyperion still starts. seems ok, thx


    (although, if you happen to know if libreelec has a kindofa start script, that would be still handy for me, for eg, i would boot to textmode, no koidi, and then the sript still could run hyperion on boot. )
     
  2. Paulchen-Panther

    Paulchen-Panther Moderator Staff Member Developer

    Messages:
    824
    Hardware:
    RPi1/Zero, RPi3, 32/64bit, +Arduino, +nodeMCU/ESP8266
    What?
    Screenshot_1.jpg
     
  3. Zoltán Varga

    Zoltán Varga Member

    Messages:
    37
    Hardware:
    RPi1/Zero, RPi3, 32/64bit, +nodeMCU/ESP8266
    ok, i missread two lines below, sorry :)
    (any idea on autostart for eg a bash script on libre?)
     
  4. Paulchen-Panther

    Paulchen-Panther Moderator Staff Member Developer

    Messages:
    824
    Hardware:
    RPi1/Zero, RPi3, 32/64bit, +Arduino, +nodeMCU/ESP8266
  5. Zoltán Varga

    Zoltán Varga Member

    Messages:
    37
    Hardware:
    RPi1/Zero, RPi3, 32/64bit, +nodeMCU/ESP8266
    ok, i get it, thanks for the help with kodi not to start, with mask,
    but there could be a hyperion releated question like this:

    how is it possible to start hyperion if libreelec is set to boot to textmode ? :)

    Hyperion:~ # cat /flash/cmdline.txt
    boot=/dev/mmcblk0p1 disk=/dev/mmcblk0p2 quiet textmode

    But ok, ill try to find a solution for this, and post it here when i find a way to do it,
    until then kodi stays masked :)

    thanks again.
     
    Last edited: 1 September 2020
  6. Artorious8

    Artorious8 New Member

    Messages:
    9
    Hardware:
    RPi3
    Hey guys, I'm pretty new to this but I've read through the entire thread and can't seem to get my hyperion started.
    I'm running a Pi Zero w with Libre 9.2.4. I've tried installing ever version on Hyperion. NG using the script but it never starts up. When I run "systemctl status hyperion.service" I get this

    hyperion.service - Hyperion ambient light systemd service
    Loaded: loaded (/storage/.config/system.d/hyperion.service; enabled; vendor preset: disabled)
    Active: activating (auto-restart) (Result: signal) since Wed 2020-09-09 21:22:50 UTC; 8s ago
    Process: 418 ExecStart=/storage/hyperion/bin/hyperiond --userdata /storage/hyperion/ (code=killed, signal=ILL)
    Main PID: 418 (code=killed, signal=ILL)

    It never fully activates.

    Any help would be great, Thanks :)
     
  7. Lord-Grey

    Lord-Grey Moderator Staff Member Developer

    Messages:
    204
    Hardware:
    RPi3, 32/64bit
    This indicates an „Illegal Instruction„
    Are you sure that you downloaded the correct Hyperion version for rpi zero? Alternatively your installation might got corrupted.
     
  8. Artorious8

    Artorious8 New Member

    Messages:
    9
    Hardware:
    RPi3
    I'm not sure if I'm using the right method to download. I used both of these scripts
    "wget -qO- https://git.io/JUvg7 | bash"

    "wget -qO- https://git.io/JUvg7 | bash -s 2.0.0-alpha.(1-7)"

    to download and everything seemed to go fine

    Thanks for replying so fast btw
     
  9. TPmodding

    TPmodding Administrator Staff Member Administrator

    Messages:
    1,849
    Hardware:
    RPi1/Zero, RPi2, RPi3, +Arduino, +nodeMCU/ESP8266
  10. Artorious8

    Artorious8 New Member

    Messages:
    9
    Hardware:
    RPi3
    Yes I think so. I copied and the script as it is into putty and hit enter.
     
  11. TPmodding

    TPmodding Administrator Staff Member Administrator

    Messages:
    1,849
    Hardware:
    RPi1/Zero, RPi2, RPi3, +Arduino, +nodeMCU/ESP8266
    is it ok for you to setup a new libre elec image and then hit
    wget -qO- https://git.io/JUvg7 | bash -s 2.0.0-alpha.7
    and show us the output?
     
  12. Artorious8

    Artorious8 New Member

    Messages:
    9
    Hardware:
    RPi3
    Sure give me a little bit to set it up again and I'll post a screen cap when I'm done
     
  13. Artorious8

    Artorious8 New Member

    Messages:
    9
    Hardware:
    RPi3
    Ok fresh Libre 9.2.4 install. Connected to putty and ran "wget -qO- https://git.io/JUvg7 | bash -s 2.0.0-alpha.7" this was the outcome Screenshot (37).png Screenshot (38).png
     
  14. Zoltán Varga

    Zoltán Varga Member

    Messages:
    37
    Hardware:
    RPi1/Zero, RPi3, 32/64bit, +nodeMCU/ESP8266
    ( i know its not a good answer to your question, its just an advice:)
    as "always" try alpha6, 7 wont work properly anyway (i had 7 on my pi zero and i ended up using alpha 6) )
     
  15. Artorious8

    Artorious8 New Member

    Messages:
    9
    Hardware:
    RPi3
    Thanks, I have tried alpha.6 also but with the same results :/ Which version of Libre are you running?
     
  16. Zoltán Varga

    Zoltán Varga Member

    Messages:
    37
    Hardware:
    RPi1/Zero, RPi3, 32/64bit, +nodeMCU/ESP8266
    I had the latest and one before that on my rpi zero + alpha 6 and worked perfectly.

    Currently i have rpi4+latest+alpha6
     
  17. Lucky007

    Lucky007 Member

    Messages:
    52
    Hardware:
    RPi3, 32/64bit
    @Paulchen-Panther
    Warum funktioniert das nicht mehr? Ich wollte ein neues Pull Request installieren
    Liegt das an der neusten LibreELEC Version?

    LibreELEC:~ # wget -qO- https://git.io/JJr6Y | bash -s 1002
    *******************************************************************************
    This script will download a specific Pull Request Artifact from Hyperion.NG on LibreELEC
    Created by Paulchen-Panther - hyperion-project.org - the official Hyperion source.
     
  18. Paulchen-Panther

    Paulchen-Panther Moderator Staff Member Developer

    Messages:
    824
    Hardware:
    RPi1/Zero, RPi3, 32/64bit, +Arduino, +nodeMCU/ESP8266
    @Lucky007
    Die Artefaktnamen haben sich geändert.
    Werde das Script dieses WE noch anpassen. Sage dir bescheid wenn es wieder funktioniert.
     
    • Agree Agree x 1
  19. Paulchen-Panther

    Paulchen-Panther Moderator Staff Member Developer

    Messages:
    824
    Hardware:
    RPi1/Zero, RPi3, 32/64bit, +Arduino, +nodeMCU/ESP8266
    @Artorious8 Could you please stop the service and start Hyperion manually in debug mode?
    Code:
    systemctl stop hyperion.service
    ./storage/hyperion/bin/hyperiond -d --userdata /storage/hyperion/
    
    edit: And please post the console output. Thank you very much.
     
  20. Paulchen-Panther

    Paulchen-Panther Moderator Staff Member Developer

    Messages:
    824
    Hardware:
    RPi1/Zero, RPi3, 32/64bit, +Arduino, +nodeMCU/ESP8266
    @Lucky007 and @all PR Testers

    G: Das PR Test Script wurde aktualisiert. Jetzt mit Start Script.
    E: The PR test script has been updated. Now with start script.

    Post 26789
     
    • Like Like x 2