1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

SOLVED HTTP Json Start Stop Instance not working

Discussion in 'Software Support' started by jonaspaulo, 31 August 2020.

  1. jonaspaulo

    jonaspaulo New Member

    Messages:
    12
    Hi,

    I am trying to start /stop the instance 0 (Led Hardware) through HTTP in order to simulate the behaviour of clicking here in the WEB UI:


    [​IMG]


    I thought this API Call did the same or not?


    So I followed the guide: https://docs.hyperion-project.org/en/json/#http-s-json and https://docs.hyperion-project.org/en/json/control.html#control-instances

    And it doesn't seem to work (Example of the POST request attached). I get a HTTP 200 but the LED Instance doesn't turn off.
    If I try with startInstance subcommand at least I get something on the logs (of course it is already started):
    Code:
    Aug 31 18:32:49 raspberrypi hyperiond[1944]: 2020-08-31T18:32:49.606 hyperiond HTTPJSONRPC  : <DEBUG> JsonAPI.cpp:107:handleInstanceSwitch() | Client '::ffff:X.X.X.X' switch to Hyperion instance 0
    Aug 31 18:32:49 raspberrypi hyperiond[1944]: 2020-08-31T18:32:49.654 hyperiond HYPERION     : <DEBUG> HyperionIManager.cpp:109:startInstance() | Can't start Hyperion instance index '0' with name 'First LED Hardware instance' it's already running or queued for start

    Although If I try to start it with the Instance on a OFF state it also doesn't work.

    If I try to set the color for example it works


    P.S. Running the latest beta (Hyperion-2.0.0-alpha.7-Linux-armv6l.deb) on Rhassbian RPI3

    Thanks
     

    Attached Files:

    Last edited: 31 August 2020
  2. jonaspaulo

    jonaspaulo New Member

    Messages:
    12
    Solved thanks to the help of Paulchen-Panther on github. I was using the wrong command.
    For reference the correct payload to Disable the instance is:

    {
    "command":"componentstate",
    "componentstate":{
    "component":"ALL",
    "state":false
    }
    }
     
    • Like Like x 1