1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

RPi + LibreELEC Hyperion autostart automatically

Discussion in 'Software Support' started by xevipc1, 29 December 2018.

  1. xevipc1

    xevipc1 New Member

    Messages:
    3
    Hardware:
    RPi3
    hi everyone,
    I have set ambilight hyperion with libreelec but I have a concern.
    If I power Rpi off, after restarting, hyperion does not start automatically, i need to go through hyperion creator again and start it manually. It’s quite tidious.
    Is there any command via putty or edit autostart.sh file to set hyperion autostarts after power off?
    Thank you so much!
     
  2. Mitch7391

    Mitch7391 New Member

    Messages:
    29
    Hardware:
    RPi3
    I have the same problem and have not found a solution. Hopefully someone provides some help.
     
  3. Akriss

    Akriss Active Member

    Messages:
    510
    Hardware:
    RPi1/Zero, RPi2, RPi3, 32/64bit, +Arduino, +nodeMCU/ESP8266
    From a ssh terminal try:
    Code:
    systemctl enable service.hyperion.service
    If it still does not start, what are the results from:
    Code:
    systemctl status service.hyperion.service
    It's possible that adding:
    Code:
    RestartSec=15
    to the startup service file might help as well.
     
    • Like Like x 1
  4. Georg

    Georg New Member

    Messages:
    4
    Hardware:
    RPi3
    I have the same problem and can’t figure out a solution. Does it matter at what position in the config file RestartSec is written?
    Can someone please show the correct config?
     
  5. Akriss

    Akriss Active Member

    Messages:
    510
    Hardware:
    RPi1/Zero, RPi2, RPi3, 32/64bit, +Arduino, +nodeMCU/ESP8266
    It's placed under the "[Service]" section, last line in that section is fine.

    Hope it's of helps.
     
  6. Georg

    Georg New Member

    Messages:
    4
    Hardware:
    RPi3
    I have just tested it without success.

    This is my config:

    [Unit]
    Description=Hyperion Systemd service

    [Service]
    Type=simple
    User=root
    Group=root
    UMask=007
    ExecStart=/usr/bin/hyperiond /etc/hyperion/hyperion.config.json
    ExecReload=/bin/kill -HUP $MAINPID
    Restart=on-failure
    TimeoutStopSec=10
    RestartSec=20

    [Install]
    WantedBy=multi-user.target

    Anybody having further ideas?

    If I open a console and enter:

    sudo killall hyperiond
    sudo service hyperion start
    nohup hyperion-v4l2 &

    ... it starts immediately.
     
  7. Akriss

    Akriss Active Member

    Messages:
    510
    Hardware:
    RPi1/Zero, RPi2, RPi3, 32/64bit, +Arduino, +nodeMCU/ESP8266
    Are you positive that the service file it's enabled at startup?

    Running,
    Code:
    systemctl status service.hyperion.service
    After a failed startup, could uncover or hint to what is going wrong.
     
  8. jwo

    jwo New Member

    Messages:
    1
    Hardware:
    RPi2
    I had the same problem. My initial work around was to install "Raspberry SSH Lite" on my phone and assign one button to "kill hyperiod" and another button to "systemctl start hyperion.service" which worked fine. My final fix was to replace the OS with Jessie and autostart on reboot is fine. for what's worth. Stretch also has the same issue with restart after reboot.