1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Hyperion.NG Pi-Zero W [hyperiond V4L2:auto] <ERROR>

Discussion in 'Bug Reports' started by JaY_III, 13 November 2019.

  1. JaY_III

    JaY_III New Member

    Messages:
    11
    Hardware:
    RPi1/Zero
    My Seup is
    Pi Zero W
    Streech Lite (also tried buster)
    Bus 001 Device 005: ID 1b71:3002 Fushicai USBTV007 Video Grabber [EasyCAP]

    First off, I had this all working from a Dec 2018 build of Hyperion.NG
    No major issues to report from then.
    However I wanted to update and try the latest build.

    Fresh install of Raspbian
    Build from here: https://github.com/hyperion-project/hyperion.ng/blob/master/CompileHowto.md

    When "Enable USB Capture" is selected I get this console output

    Code:
    [hyperiond V4L2:auto] <ERROR> Throws error nr: VIDIOC_DQBUF error code 19, No such device
    [hyperiond V4L2:auto] <ERROR> Previous line repeats 200 times
    [hyperiond V4L2:auto] <ERROR> Previous line repeats 166 times
    [hyperiond V4L2:auto] <ERROR> VIDIOC_STREAMOFF  error code  19, No such device
    
    When I attempt to manually set the device from auto to:
    /dev/video0
    I still get the same error saying its on auto

    Possibly related to this closed issue
    https://github.com/hyperion-project/hyperion.ng/issues/542


    Please let me know if I can test anything or provide more information.
     
  2. JaY_III

    JaY_III New Member

    Messages:
    11
    Hardware:
    RPi1/Zero
    rebuilt today with clean stretch install
    Built like this:

    wget -qO- https://raw.githubusercontent.com/brindosch/hyperion.ngBeta/master/bin/compile.sh | sh

    lsusb
    listed my capture card as per normal, still not working

    Ended up disconnecting and reconnecting everything and now it all works.
    I think even though the system saw the capture card the connection may have not been the best perhaps?

    Either way its working now