1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

SOLVED Hyperion.ng: Random and fast lights with dark colors

Discussion in 'Software Support' started by Rogerio, 4 April 2019.

  1. Rogerio

    Rogerio New Member


    First of all, the title isn't clear enough so I'm sorry about that.

    I have a RPi 3B+ running Raspian with around 220 WS2812B leds connected via SPI + STK1160 grabber and a 12A 5V power supply. No logic level, but a 470 Ohm between the RPi and the data wire, soldered. The cable between the RPi and the strips has around 1m.

    The 4m strip is split in 4 smaller strips and the ground + data is soldered between then. The +5V is directly connected to the power supply.

    The issue that I'm having is completely the oposite of the majority. I can light up all my leds in white with no issues and no weird/orange colors, but I get random and colorful colors when I get dark scenes OR I set a dark color (close to black up to full black) manually using the webconfig or hyperion-remote.

    If I enable the grabber on a bright movie and/or manually select an effect or a bright static color the leds lights up beautifully.
    I also tried the offical test (python and C) scripts from the WS2812B library, no issues at all.

    My first thought was related to the blackborder detection, which I tried to disable/enable and change settings. I also thought it could be related to the backlight color or backlight threshold. No lucky.

    My hyperion is compiled from the master branch and it is up-to-date:

    [email protected]:~# hyperiond --version
    Hyperion Ambilight Deamon (1593)
    Version : 2.0.0 (master (GitHub-3a8e6dc9/ea044977-1554226519) Git Remote: https://github.com/hyperion-project/hyperion.ng.git)
    Build Time: Apr 3 2019 20:45:25

    My config is here:

    And here is a video with the issue happening:


    Here is my hyperion-log using --debug:

    my /boot/config.txt has:

    and my /boot/cmdline.txt has in the end:

    [email protected]:~# uname -a
    Linux pibrewer 4.14.98-v7+ #1200 SMP Tue Feb 12 20:27:48 GMT 2019 armv7l GNU/Linux

    [email protected]:~# cat /etc/issue
    Raspbian GNU/Linux 9 \n \l

    [email protected]:~# lsusb |grep -i video
    Bus 001 Device 004: ID 05e1:0408 Syntek Semiconductor Co., Ltd STK1160 Video Capture Device

    [email protected]:~# ls /dev/spidev*
    /dev/spidev0.0 /dev/spidev0.1

    output of v4l2-ctl --all:

    Last edited: 4 April 2019
  2. TPmodding

    TPmodding Administrator Staff Member Administrator

    RPi1/Zero, RPi2, RPi3, +Arduino, +nodeMCU/ESP8266
    hahaha buddyyyyyy

    this not a random flashing...the blackborder cuts the picture till the blue loading circle and then shows you the moving colors :)

    edit: if you go to the webinterface from hyperion.ng than you can see live the picture, there you should see the blue loading circle
  3. Rogerio

    Rogerio New Member

    Hey bro.. Thanks for the reply..

    I've always thought it could be the blackborder, but I got the 'issue' even disabling it or using static colors.

    To be honest, I just needed a little bit more patience and a sleep :sleep::sleep:. I got an arduino delivered today so I rebuilt the connections.. RPi -> arduino -> Leds.
    The config is exactly the same (except the device part).

    To my surprise? The Leds didnt light up at all. The issue? The long (1m) cable between the arduino and the leds.
    I moved the arduino to the closest connection as possible and tadaaaaa.. :D lights are perfect and no blinking (or whatever we may call it) issue anymore.. Even with the loading circle (which is grey, not blue).

    What about the original issue when the leds were connected directly to the RPi via SPI? I have no idea. :crying::crying::crying: but I don't want try that again.

    I've never thought it could be the cable tho. 1m isn't long and the cable isn't that tiny (20awg).

    Thanks again.
  4. TPmodding

    TPmodding Administrator Staff Member Administrator

    RPi1/Zero, RPi2, RPi3, +Arduino, +nodeMCU/ESP8266
    Long Cable is always a problem... the siganl has to be vcc*0,7, and with the long cable the voltage drops and it has not enough "power" when it reaches the LEDs