1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Hyperion.ng startet nach update auf alpha6 nicht mehr

Discussion in 'German Talk' started by u20p17, 31 May 2020.

  1. u20p17

    u20p17 New Member

    Messages:
    18
    Hi,
    habe heute auf die alpha 6 version upgedated und seitdem habe ich keinen zugriff mehr auf die weboberfläche.

    Für die installation bin ich folgendermaßen vorgegangen:
    git clone --recursive https://github.com/hyperion-project/hyperion.ng.git hyperion
    cd hyperion
    mkdir build
    cd build
    cmake -DCMAKE_BUILD_TYPE=Release ..
    make -j $(nproc)
    sudo make install/strip

    danach habe ich die ip:8090 aufgerufen, jedoch passiert dann nix mehr. Wie kann ich einen log erzeugen, um auf das problem zu kommen?

    LG

    PS:
    Raspberry Pi 4 Modell B 4GB SDRAM
    Operating System: Raspian Buster with Desktop
    Kernel: 5.4.42-v7l+
    Node.js: v12.17.0
    NPN: v6.14.5

    EDIT: wenn ich mittels dem befehl 'top' den arbeitsspeicher anschau benötigt hyperion 1.5GB Ram und 71% CPU...
     
    Last edited: 31 May 2020
  2. Paulchen-Panther

    Paulchen-Panther Moderator Staff Member Developer

    Messages:
    857
    Hardware:
    RPi1/Zero, RPi3, 32/64bit, +Arduino, +nodeMCU/ESP8266
  3. u20p17

    u20p17 New Member

    Messages:
    18
    Hi,
    habe sudo apt-cache search hyperion eingegeben und das resultat war

    [email protected]:~ $ sudo apt-cache search hyperion
    charybdis - fast, scalable irc server
    ttf-aenigma - 465 free TrueType fonts by Brian Kent

    Mach ich da was falsch?

    Habe es nun mittels

    sudo make uninstall

    deinstalliert, dann mittels

    wget -qO- https://raw.githubusercontent.com/hyperion-project/hyperion.ng/master/bin/compile.sh | sh

    erneut installiert und dann den raspbi neu gestartet. Komme aber noch immer nicht aufs Webinterface. Wenn ich nun mit 'top' den Prozess suche finde ich nun kein hyperion mehr in der liste...
     
  4. Paulchen-Panther

    Paulchen-Panther Moderator Staff Member Developer

    Messages:
    857
    Hardware:
    RPi1/Zero, RPi3, 32/64bit, +Arduino, +nodeMCU/ESP8266
  5. Paulchen-Panther

    Paulchen-Panther Moderator Staff Member Developer

    Messages:
    857
    Hardware:
    RPi1/Zero, RPi3, 32/64bit, +Arduino, +nodeMCU/ESP8266
    Ja du tust Hyperion selber kompilieren. Du sollst die deb Datei auf GitHub installieren. Kann doch nicht so schwer sein.
     
  6. u20p17

    u20p17 New Member

    Messages:
    18
    Hallo,
    sorry dafür. (bin ein LinuxNeuling)
    habe es nun mittels sudo dpkg -i Hyperion-2.0.0-alpha.6-Linux-armv7l.deb installiert und danach den raspbi wieder neu gestartet. Leider habe ich noch immer dasselbe Problem --> ip:8090 (bzw. 8091) kann ich mich nicht verbinden... im taskmanager vom rasbi sehe ich anfangs nen hyperiond task, der ca. 30 cpu und >1.7Gb RAM benötigt (steigt stetig an) und nach einer gewissen Zeit verschwindet der Task. wenn ich dann Hyperion erneut ausführe beginnt das spiel von vorne.
     
  7. Paulchen-Panther

    Paulchen-Panther Moderator Staff Member Developer

    Messages:
    857
    Hardware:
    RPi1/Zero, RPi3, 32/64bit, +Arduino, +nodeMCU/ESP8266
    Werd es morgen testen. Danke
     
  8. u20p17

    u20p17 New Member

    Messages:
    18
    Perfekt, danke!

    Vielleicht hängt es irgendwie mit der Kernel-Version vom Raspbi 4b zusammen? Diese habe ich heute auch upgedated, damit ich die SD-Karte gegen eine SSD ersetzen kann und direkt davon booten kann...

    LG
     
  9. Paulchen-Panther

    Paulchen-Panther Moderator Staff Member Developer

    Messages:
    857
    Hardware:
    RPi1/Zero, RPi3, 32/64bit, +Arduino, +nodeMCU/ESP8266
    Ich hätte da noch ein paar Fragen.

    Welche LED's hast du und wie steuerst du diese an?
    Betreibst du noch Raspbian Buster mit Desktop oder schon Raspberry Pi OS?
     
  10. u20p17

    u20p17 New Member

    Messages:
    18
    Hi,
    bin gerade dabei auf apa102 umzusteigen... Zurzeit sind keine LEDs am Raspberry angehängt. Als Betriebssystem verwende ich Raspbian Buster with desktop.

    LG
     
  11. Paulchen-Panther

    Paulchen-Panther Moderator Staff Member Developer

    Messages:
    857
    Hardware:
    RPi1/Zero, RPi3, 32/64bit, +Arduino, +nodeMCU/ESP8266
    Raspbian Buster mit Desktop habe ich installiert. Sowie die armv7l.deb Datei von GitHub.
    Abgesehen davon das kein Systray vorhanden ist startet Hyperion und das Web UI ist erreichbar.
    Kann also nur ein Konflikt mit einem anderem Dienst bei Dir bestehen.
    Postest du mir bitte die Ausgabe von
    Code:
    netstat -tanp
    deb_installed_and_opend_webui.png system_info_webui.png
     
  12. u20p17

    u20p17 New Member

    Messages:
    18
    Hi,
    anbei die ausgabe:

    Aktive Internetverbindungen (Server und stehende Verbindungen)
    Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
    tcp 0 0 0.0.0.0:8088 0.0.0.0:* LISTEN 900/deCONZ
    tcp 0 0 0.0.0.0:80 0.0.0.0:* LISTEN 900/deCONZ
    tcp 0 0 0.0.0.0:22 0.0.0.0:* LISTEN 567/sshd
    tcp 0 0 127.0.0.1:34290 127.0.0.1:80 TIME_WAIT -
    tcp 0 0 127.0.0.1:34354 127.0.0.1:80 TIME_WAIT -
    tcp 0 0 127.0.0.1:34366 127.0.0.1:80 TIME_WAIT -
    tcp 0 0 127.0.0.1:34334 127.0.0.1:80 TIME_WAIT -
    tcp 0 0 127.0.0.1:34288 127.0.0.1:80 TIME_WAIT -
    tcp 0 0 127.0.0.1:34260 127.0.0.1:80 TIME_WAIT -
    tcp 0 0 127.0.0.1:34370 127.0.0.1:80 TIME_WAIT -
    tcp 0 0 127.0.0.1:34266 127.0.0.1:80 TIME_WAIT -
    tcp 0 0 127.0.0.1:34316 127.0.0.1:80 TIME_WAIT -
    tcp 0 0 127.0.0.1:34360 127.0.0.1:80 TIME_WAIT -
    tcp 0 0 127.0.0.1:34254 127.0.0.1:80 TIME_WAIT -
    tcp 0 0 127.0.0.1:34292 127.0.0.1:80 TIME_WAIT -
    tcp 0 0 127.0.0.1:34256 127.0.0.1:80 TIME_WAIT -
    tcp 0 0 127.0.0.1:34248 127.0.0.1:80 TIME_WAIT -
    tcp 0 0 127.0.0.1:34262 127.0.0.1:80 TIME_WAIT -
    tcp 0 0 127.0.0.1:34244 127.0.0.1:80 TIME_WAIT -
    tcp 0 0 127.0.0.1:34344 127.0.0.1:80 TIME_WAIT -
    tcp 0 0 127.0.0.1:34304 127.0.0.1:80 TIME_WAIT -
    tcp 0 0 127.0.0.1:34306 127.0.0.1:80 TIME_WAIT -
    tcp 0 0 127.0.0.1:34276 127.0.0.1:80 TIME_WAIT -
    tcp 0 0 127.0.0.1:49558 127.0.0.1:43495 VERBUNDEN 8138/homebridge
    tcp 0 0 127.0.0.1:34246 127.0.0.1:80 TIME_WAIT -
    tcp 0 400 10.0.0.10:22 10.0.0.15:57498 VERBUNDEN 3997/sshd: pi [priv
    tcp 0 0 127.0.0.1:34376 127.0.0.1:80 TIME_WAIT -
    tcp 0 0 10.0.0.10:8088 10.0.0.10:48626 VERBUNDEN 900/deCONZ
    tcp 0 0 127.0.0.1:34296 127.0.0.1:80 TIME_WAIT -
    tcp 0 0 127.0.0.1:34298 127.0.0.1:80 TIME_WAIT -
    tcp 0 0 127.0.0.1:34240 127.0.0.1:80 TIME_WAIT -
    tcp 0 0 127.0.0.1:34264 127.0.0.1:80 TIME_WAIT -
    tcp 0 0 127.0.0.1:34368 127.0.0.1:80 TIME_WAIT -
    tcp 0 0 127.0.0.1:34346 127.0.0.1:80 TIME_WAIT -
    tcp 0 0 127.0.0.1:34286 127.0.0.1:80 TIME_WAIT -
    tcp 0 0 127.0.0.1:34342 127.0.0.1:80 TIME_WAIT -
    tcp 0 0 127.0.0.1:34280 127.0.0.1:80 TIME_WAIT -
    tcp 0 0 127.0.0.1:34362 127.0.0.1:80 TIME_WAIT -
    tcp 0 0 127.0.0.1:34332 127.0.0.1:80 TIME_WAIT -
    tcp 0 0 127.0.0.1:34374 127.0.0.1:80 TIME_WAIT -
    tcp 0 0 127.0.0.1:34320 127.0.0.1:80 TIME_WAIT -
    tcp 0 0 127.0.0.1:34352 127.0.0.1:80 TIME_WAIT -
    tcp 0 0 127.0.0.1:34268 127.0.0.1:80 TIME_WAIT -
    tcp 0 0 127.0.0.1:34284 127.0.0.1:80 TIME_WAIT -
    tcp 0 0 127.0.0.1:34358 127.0.0.1:80 TIME_WAIT -
    tcp 0 0 127.0.0.1:34252 127.0.0.1:80 TIME_WAIT -
    tcp 0 0 127.0.0.1:34310 127.0.0.1:80 TIME_WAIT -
    tcp 0 0 127.0.0.1:34314 127.0.0.1:80 TIME_WAIT -
    tcp 0 0 127.0.0.1:34364 127.0.0.1:80 TIME_WAIT -
    tcp 0 0 127.0.0.1:34258 127.0.0.1:80 TIME_WAIT -
    tcp 0 0 127.0.0.1:34300 127.0.0.1:80 TIME_WAIT -
    tcp 0 0 127.0.0.1:34338 127.0.0.1:80 TIME_WAIT -
    tcp 0 0 127.0.0.1:34272 127.0.0.1:80 TIME_WAIT -
    tcp 0 0 127.0.0.1:34348 127.0.0.1:80 TIME_WAIT -
    tcp 0 0 127.0.0.1:34328 127.0.0.1:80 TIME_WAIT -
    tcp 0 0 10.0.0.10:38930 35.158.19.84:443 VERBUNDEN 8138/homebridge
    tcp 0 0 127.0.0.1:34274 127.0.0.1:80 TIME_WAIT -
    tcp 0 0 127.0.0.1:34330 127.0.0.1:80 TIME_WAIT -
    tcp 0 0 127.0.0.1:34282 127.0.0.1:80 TIME_WAIT -
    tcp 0 0 127.0.0.1:34326 127.0.0.1:80 TIME_WAIT -
    tcp 0 0 10.0.0.10:80 10.0.0.10:33848 VERBUNDEN 900/deCONZ
    tcp 0 0 10.0.0.10:33848 10.0.0.10:80 VERBUNDEN 8138/homebridge
    tcp 0 0 127.0.0.1:34324 127.0.0.1:80 TIME_WAIT -
    tcp 0 0 127.0.0.1:34242 127.0.0.1:80 TIME_WAIT -
    tcp 0 0 10.0.0.10:48626 10.0.0.10:8088 VERBUNDEN 8138/homebridge
    tcp 0 0 127.0.0.1:34378 127.0.0.1:80 TIME_WAIT -
    tcp 0 0 127.0.0.1:34312 127.0.0.1:80 TIME_WAIT -
    tcp 0 0 127.0.0.1:34318 127.0.0.1:80 TIME_WAIT -
    tcp 0 0 127.0.0.1:34270 127.0.0.1:80 TIME_WAIT -
    tcp 0 0 127.0.0.1:34278 127.0.0.1:80 TIME_WAIT -
    tcp 0 0 127.0.0.1:34336 127.0.0.1:80 TIME_WAIT -
    tcp 0 0 127.0.0.1:34340 127.0.0.1:80 TIME_WAIT -
    tcp 0 0 127.0.0.1:34302 127.0.0.1:80 TIME_WAIT -
    tcp 0 0 127.0.0.1:34356 127.0.0.1:80 TIME_WAIT -
    tcp 0 0 127.0.0.1:34350 127.0.0.1:80 TIME_WAIT -
    tcp 0 0 127.0.0.1:34322 127.0.0.1:80 TIME_WAIT -
    tcp 0 0 127.0.0.1:34380 127.0.0.1:80 TIME_WAIT -
    tcp 0 0 127.0.0.1:34372 127.0.0.1:80 TIME_WAIT -
    tcp 0 0 127.0.0.1:34250 127.0.0.1:80 TIME_WAIT -
    tcp 0 0 127.0.0.1:34294 127.0.0.1:80 TIME_WAIT -
    tcp6 0 0 :::443 :::* LISTEN 604/domoticz
    tcp6 0 0 :::6144 :::* LISTEN 604/domoticz
    tcp6 0 0 :::8070 :::* LISTEN 604/domoticz
    tcp6 0 0 :::43495 :::* LISTEN 8138/homebridge
    tcp6 0 0 :::8080 :::* LISTEN 8231/homebridge-con
    tcp6 0 0 :::51826 :::* LISTEN 8138/homebridge
    tcp6 0 0 :::22 :::* LISTEN 567/sshd
    tcp6 0 0 127.0.0.1:43495 127.0.0.1:49558 VERBUNDEN 8138/homebridge
    tcp6 0 0 10.0.0.10:8070 10.0.0.15:57226 VERBUNDEN 604/domoticz
    tcp6 0 0 10.0.0.10:51826 10.0.0.6:61794 VERBUNDEN 8138/homebridge
     
  13. Paulchen-Panther

    Paulchen-Panther Moderator Staff Member Developer

    Messages:
    857
    Hardware:
    RPi1/Zero, RPi3, 32/64bit, +Arduino, +nodeMCU/ESP8266
    Wenn du die deb installiert hast, starte doch mal hyperion von der Konsole aus.

    1. Herausfinden ob der Hyperion Dienst läuft (loaded active running)
    Code:
    systemctl | grep hyperion
    2. Wenn ja, stoppen des Dienstes (bei mir heißt die systemd datei [email protected]). Der Name der systemd Datei sollte in Punkt 1 angezeigt werden
    Code:
    sudo systemctl stop [email protected]
    3. Hyperion manuell im Debug modus starten.
    Code:
    hyperiond -d


    Und davon hätte ich auch deine Ausgabe bitte. Danke
     
  14. u20p17

    u20p17 New Member

    Messages:
    18
    Hi,
    danke für deine Bemühungen. Anbei die Ausgabe von hyperiond -d

    hyperiond -d
    [hyperiond MAIN] <INFO> Set user data path to '/home/pi/.hyperion'
    [hyperiond DAEMON] <DEBUG> <PythonInit.cpp:45:pythonInit()> Initializing Python interpreter
    [hyperiond SettingsManager] <DEBUG> <SettingsManager.cpp:108:SettingsManager()> Settings database initialized
    [hyperiond EFFECTFILES] <INFO> 39 effects loaded from directory :/effects/
    [hyperiond EFFECTFILES] <INFO> 22 effect schemas loaded from directory :/effects/schema/
    [hyperiond EFFECTFILES] <INFO> 0 effects loaded from directory /home/pi/.hyperion/custom-effects
    [hyperiond SettingsManager] <DEBUG> <SettingsManager.cpp:108:SettingsManager()> Settings database initialized
    [hyperiond BLACKBORDER] <DEBUG> <BlackBorderProcessor.cpp:65:handleSettingsUpdate()> Set mode to: default
    [hyperiond ComponentRegister] <DEBUG> <ComponentRegister.cpp:36:setNewComponentState()> Blackborder detector: enabled
    [hyperiond DAEMON] <INFO> set screen capture device to 'dispmanx'
    [hyperiond DISPMANXGRABBER] <DEBUG> <Grabber.cpp:34:setVideoMode()> Set videomode to 0
    [hyperiond DISPMANXGRABBER] <INFO> Display opened with resolution: 1920x1080
    [hyperiond DISPMANXGRABBER] <DEBUG> <Grabber.cpp:83:setWidthHeight()> Set new width: 80, height: 45 for capture
    [hyperiond DAEMON] <INFO> DISPMANX frame grabber created
    [hyperiond V4L2:auto] <DEBUG> <Grabber.cpp:34:setVideoMode()> Set videomode to 0
    [hyperiond LEDDEVICE] <INFO> LedDevice 'apa102' found.
    [hyperiond LEDDEVICE] <DEBUG> <ProviderSpi.cpp:55:eek:pen()> _baudRate_Hz [1000000], _latchTime_ms [1]
    [hyperiond LEDDEVICE] <DEBUG> <ProviderSpi.cpp:56:eek:pen()> _spiDataInvert [0], _spiMode [0]
    [hyperiond ComponentRegister] <DEBUG> <ComponentRegister.cpp:36:setNewComponentState()> Smoothing: enabled
    [hyperiond FLATBUFCONNECTION] <INFO> Connecting to Hyperion: 127.0.0.1:19401
    [hyperiond EFFECTENGINE] <INFO> Run effect "Rainbow swirl fast" on channel 0
    [hyperiond EFFECTENGINE] <DEBUG> <EffectEngine.cpp:183:runEffectScript()> Start the effect: name [Rainbow swirl fast], smoothCfg [2]
    [hyperiond HYPERION] <DEBUG> <PriorityMuxer.cpp:158:registerInput()> Register new input 'System/EFFECT' with priority 0 as inacti ve
    [hyperiond HYPERION] <INFO> Initial foreground effect 'Rainbow swirl fast' started
    [hyperiond EFFECTENGINE] <INFO> Run effect "Warm mood blobs" on channel 254
    [hyperiond EFFECTENGINE] <DEBUG> <EffectEngine.cpp:183:runEffectScript()> Start the effect: name [Warm mood blobs], smoothCfg [2]
    [hyperiond HYPERION] <DEBUG> <PriorityMuxer.cpp:158:registerInput()> Register new input 'System/EFFECT' with priority 254 as inac tive
    [hyperiond HYPERION] <INFO> Inital background effect 'Warm mood blobs' started
    [hyperiond HYPERION] <DEBUG> <PriorityMuxer.cpp:158:registerInput()> Register new input 'System/GRABBER' with priority 250 as ina ctive
    [hyperiond ComponentRegister] <DEBUG> <ComponentRegister.cpp:36:setNewComponentState()> Framegrabber: enabled
    [hyperiond BOBLIGHT] <DEBUG> <BoblightServer.cpp:28:BoblightServer()> Instance created
    [hyperiond ComponentRegister] <DEBUG> <ComponentRegister.cpp:36:setNewComponentState()> LED device: enabled
    [hyperiond HYPERION] <DEBUG> <PriorityMuxer.cpp:238:setInputImage()> Priority 0 is now active
    [hyperiond HYPERION] <DEBUG> <PriorityMuxer.cpp:333:setCurrentTime()> Set visible priority to 0
    [hyperiond HYPERION] <DEBUG> <PriorityMuxer.cpp:198:setInput()> Priority 254 is now active
     
  15. Paulchen-Panther

    Paulchen-Panther Moderator Staff Member Developer

    Messages:
    857
    Hardware:
    RPi1/Zero, RPi3, 32/64bit, +Arduino, +nodeMCU/ESP8266
    Hab den Kernel jetzt aktualisiert. Und du wirst es nicht glauben. Ich komme auch nicht auf das WebUI.
    Ich meld mich bei dir wenn ich was neues Berichten kann.
    Danke für deine Zeit.
     
  16. u20p17

    u20p17 New Member

    Messages:
    18
    Ok danke! Zumindest wiss ma jetzt schon wodurch es zustande kommt.

    LG
     
  17. Paulchen-Panther

    Paulchen-Panther Moderator Staff Member Developer

    Messages:
    857
    Hardware:
    RPi1/Zero, RPi3, 32/64bit, +Arduino, +nodeMCU/ESP8266
    Moment bitte. Da ist was schief gelaufen
     
    Last edited: 1 June 2020
  18. u20p17

    u20p17 New Member

    Messages:
    18
    Hi,
    gerade installiert und raspbi neu gestartet. Komme damit noch immer nicht aufs web interface.

    [email protected]:~ $ netstat -tanp
    (Es konnten nicht alle Prozesse identifiziert werden; Informationen über
    nicht-eigene Processe werden nicht angezeigt; Root kann sie anzeigen.)
    Aktive Internetverbindungen (Server und stehende Verbindungen)
    Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
    tcp 0 0 0.0.0.0:8088 0.0.0.0:* LISTEN -
    tcp 0 0 0.0.0.0:80 0.0.0.0:* LISTEN -
    tcp 0 0 0.0.0.0:22 0.0.0.0:* LISTEN -
    tcp 0 0 127.0.0.1:59498 127.0.0.1:80 TIME_WAIT -
    tcp 0 0 127.0.0.1:59512 127.0.0.1:80 TIME_WAIT -
    tcp 0 0 127.0.0.1:59434 127.0.0.1:80 TIME_WAIT -
    tcp 0 0 127.0.0.1:59460 127.0.0.1:80 TIME_WAIT -
    tcp 0 0 10.0.0.10:49010 104.16.26.35:443 TIME_WAIT -
    tcp 0 0 127.0.0.1:59520 127.0.0.1:80 TIME_WAIT -
    tcp 0 0 127.0.0.1:59428 127.0.0.1:80 TIME_WAIT -
    tcp 0 0 127.0.0.1:59240 127.0.0.1:42405 VERBUNDEN -
    tcp 0 0 127.0.0.1:59406 127.0.0.1:80 TIME_WAIT -
    tcp 0 0 127.0.0.1:59402 127.0.0.1:80 TIME_WAIT -
    tcp 0 0 127.0.0.1:59416 127.0.0.1:80 TIME_WAIT -
    tcp 0 0 10.0.0.10:8088 10.0.0.10:45426 VERBUNDEN -
    tcp 0 0 127.0.0.1:59392 127.0.0.1:80 TIME_WAIT -
    tcp 0 0 127.0.0.1:59444 127.0.0.1:80 TIME_WAIT -
    tcp 0 0 127.0.0.1:59486 127.0.0.1:80 TIME_WAIT -
    tcp 0 0 127.0.0.1:59424 127.0.0.1:80 TIME_WAIT -
    tcp 0 0 127.0.0.1:59494 127.0.0.1:80 TIME_WAIT -
    tcp 0 0 127.0.0.1:59432 127.0.0.1:80 TIME_WAIT -
    tcp 0 0 10.0.0.10:58422 35.158.19.84:443 VERBUNDEN -
    tcp 0 0 127.0.0.1:59450 127.0.0.1:80 TIME_WAIT -
    tcp 0 0 127.0.0.1:59456 127.0.0.1:80 TIME_WAIT -
    tcp 0 0 127.0.0.1:59504 127.0.0.1:80 TIME_WAIT -
    tcp 0 0 127.0.0.1:59420 127.0.0.1:80 TIME_WAIT -
    tcp 0 0 10.0.0.10:45426 10.0.0.10:8088 VERBUNDEN -
    tcp 0 0 127.0.0.1:59462 127.0.0.1:80 TIME_WAIT -
    tcp 0 0 127.0.0.1:59400 127.0.0.1:80 TIME_WAIT -
    tcp 0 0 127.0.0.1:59436 127.0.0.1:80 TIME_WAIT -
    tcp 0 0 127.0.0.1:59522 127.0.0.1:80 TIME_WAIT -
    tcp 0 0 127.0.0.1:59472 127.0.0.1:80 TIME_WAIT -
    tcp 0 0 127.0.0.1:59466 127.0.0.1:80 TIME_WAIT -
    tcp 0 0 10.0.0.10:49014 104.16.26.35:443 TIME_WAIT -
    tcp 0 0 127.0.0.1:59376 127.0.0.1:80 TIME_WAIT -
    tcp 0 0 127.0.0.1:59476 127.0.0.1:80 TIME_WAIT -
    tcp 0 0 127.0.0.1:59478 127.0.0.1:80 TIME_WAIT -
    tcp 0 0 127.0.0.1:59496 127.0.0.1:80 TIME_WAIT -
    tcp 0 0 127.0.0.1:59430 127.0.0.1:80 TIME_WAIT -
    tcp 0 0 127.0.0.1:59518 127.0.0.1:80 TIME_WAIT -
    tcp 0 0 127.0.0.1:59508 127.0.0.1:80 TIME_WAIT -
    tcp 0 0 10.0.0.10:80 10.0.0.10:59374 VERBUNDEN -
    tcp 0 0 127.0.0.1:59490 127.0.0.1:80 TIME_WAIT -
    tcp 0 0 127.0.0.1:59488 127.0.0.1:80 TIME_WAIT -
    tcp 0 0 10.0.0.10:59374 10.0.0.10:80 VERBUNDEN -
    tcp 0 0 127.0.0.1:59412 127.0.0.1:80 TIME_WAIT -
    tcp 0 0 127.0.0.1:59422 127.0.0.1:80 TIME_WAIT -
    tcp 0 0 127.0.0.1:59470 127.0.0.1:80 TIME_WAIT -
    tcp 0 0 127.0.0.1:59394 127.0.0.1:80 TIME_WAIT -
    tcp 0 0 10.0.0.10:34608 104.16.27.35:443 TIME_WAIT -
    tcp 0 2672 10.0.0.10:22 10.0.0.15:50792 VERBUNDEN -
    tcp 0 0 127.0.0.1:59482 127.0.0.1:80 TIME_WAIT -
    tcp 0 0 127.0.0.1:59484 127.0.0.1:80 TIME_WAIT -
    tcp 0 0 10.0.0.10:54812 172.217.16.116:80 VERBUNDEN -
    tcp 0 0 127.0.0.1:59446 127.0.0.1:80 TIME_WAIT -
    tcp 0 0 127.0.0.1:59474 127.0.0.1:80 TIME_WAIT -
    tcp 0 0 10.0.0.10:34604 104.16.27.35:443 TIME_WAIT -
    tcp 0 0 127.0.0.1:42332 127.0.0.1:45165 TIME_WAIT -
    tcp 0 0 127.0.0.1:59390 127.0.0.1:80 TIME_WAIT -
    tcp 0 0 127.0.0.1:59506 127.0.0.1:80 TIME_WAIT -
    tcp 0 0 127.0.0.1:59414 127.0.0.1:80 TIME_WAIT -
    tcp 0 0 10.0.0.10:49006 104.16.26.35:443 TIME_WAIT -
    tcp 0 0 127.0.0.1:59426 127.0.0.1:80 TIME_WAIT -
    tcp 0 0 127.0.0.1:59396 127.0.0.1:80 TIME_WAIT -
    tcp 0 0 127.0.0.1:59448 127.0.0.1:80 TIME_WAIT -
    tcp 0 0 127.0.0.1:59524 127.0.0.1:80 TIME_WAIT -
    tcp 0 0 127.0.0.1:59404 127.0.0.1:80 TIME_WAIT -
    tcp 0 0 127.0.0.1:59442 127.0.0.1:80 TIME_WAIT -
    tcp 0 0 127.0.0.1:59502 127.0.0.1:80 TIME_WAIT -
    tcp 0 0 127.0.0.1:59464 127.0.0.1:80 TIME_WAIT -
    tcp 0 0 127.0.0.1:59398 127.0.0.1:80 TIME_WAIT -
    tcp 0 0 127.0.0.1:59410 127.0.0.1:80 TIME_WAIT -
    tcp 0 0 127.0.0.1:59492 127.0.0.1:80 TIME_WAIT -
    tcp 0 0 127.0.0.1:59452 127.0.0.1:80 TIME_WAIT -
    tcp 0 0 127.0.0.1:59418 127.0.0.1:80 TIME_WAIT -
    tcp 0 0 10.0.0.10:34600 104.16.27.35:443 TIME_WAIT -
    tcp 0 0 127.0.0.1:59516 127.0.0.1:80 TIME_WAIT -
    tcp 0 0 127.0.0.1:59440 127.0.0.1:80 TIME_WAIT -
    tcp 0 0 127.0.0.1:59438 127.0.0.1:80 TIME_WAIT -
    tcp 0 0 127.0.0.1:59480 127.0.0.1:80 TIME_WAIT -
    tcp 0 0 127.0.0.1:59468 127.0.0.1:80 TIME_WAIT -
    tcp 0 0 127.0.0.1:59500 127.0.0.1:80 TIME_WAIT -
    tcp 0 0 127.0.0.1:59510 127.0.0.1:80 TIME_WAIT -
    tcp 0 0 127.0.0.1:59408 127.0.0.1:80 TIME_WAIT -
    tcp 0 0 127.0.0.1:59514 127.0.0.1:80 TIME_WAIT -
    tcp6 0 0 :::443 :::* LISTEN -
    tcp6 0 0 :::6144 :::* LISTEN -
    tcp6 0 0 :::42405 :::* LISTEN -
    tcp6 0 0 :::8070 :::* LISTEN -
    tcp6 0 0 :::8080 :::* LISTEN -
    tcp6 0 0 :::51826 :::* LISTEN -
    tcp6 0 0 :::22 :::* LISTEN -
    tcp6 0 0 10.0.0.10:8080 10.0.0.15:50776 TIME_WAIT -
    tcp6 0 0 10.0.0.10:51826 10.0.0.6:62659 VERBUNDEN -
    tcp6 0 0 10.0.0.10:8080 10.0.0.15:50777 VERBUNDEN -
    tcp6 0 0 10.0.0.10:8070 10.0.0.15:50761 VERBUNDEN -
    tcp6 0 0 127.0.0.1:42405 127.0.0.1:59240 VERBUNDEN -
    tcp6 0 0 10.0.0.10:8080 10.0.0.15:50778 TIME_WAIT -
    tcp6 0 0 10.0.0.10:8080 10.0.0.15:50775 TIME_WAIT -


    [email protected]:~ $ hyperiond -d
    [hyperiond MAIN] <INFO> Set user data path to '/home/pi/.hyperion'
    [hyperiond DAEMON] <DEBUG> <PythonInit.cpp:45:pythonInit()> Initializing Python interpreter
    [hyperiond SettingsManager] <DEBUG> <SettingsManager.cpp:108:SettingsManager()> Settings database initialized
    [hyperiond EFFECTFILES] <INFO> 39 effects loaded from directory :/effects/
    [hyperiond EFFECTFILES] <INFO> 22 effect schemas loaded from directory :/effects/schema/
    [hyperiond EFFECTFILES] <INFO> 0 effects loaded from directory /home/pi/.hyperion/custom-effects
    [hyperiond SettingsManager] <DEBUG> <SettingsManager.cpp:108:SettingsManager()> Settings database initialized
    [hyperiond BLACKBORDER] <DEBUG> <BlackBorderProcessor.cpp:65:handleSettingsUpdate()> Set mode to: default
    [hyperiond ComponentRegister] <DEBUG> <ComponentRegister.cpp:36:setNewComponentState()> Blackborder detector: enabled
    [hyperiond DAEMON] <INFO> set screen capture device to 'dispmanx'
    [hyperiond DISPMANXGRABBER] <DEBUG> <Grabber.cpp:34:setVideoMode()> Set videomode to 0
    [hyperiond DISPMANXGRABBER] <INFO> Display opened with resolution: 1920x1080
    [hyperiond DISPMANXGRABBER] <DEBUG> <Grabber.cpp:83:setWidthHeight()> Set new width: 80, height: 45 for capture
    [hyperiond DAEMON] <INFO> DISPMANX frame grabber created
    [hyperiond V4L2:auto] <DEBUG> <Grabber.cpp:34:setVideoMode()> Set videomode to 0
    [hyperiond V4L2:auto] <INFO> Signal threshold set to: {12, 12, 12}
    [hyperiond V4L2:auto] <INFO> Signal detection is now disabled
    [hyperiond V4L2:auto] <INFO> Signal detection area set to: 0.250000,0.250000 x 0.750000,0.750000
    [hyperiond DAEMON] <DEBUG> <hyperiond.cpp:484:handleSettingsUpdate()> V4L2 grabber created
    [hyperiond LEDDEVICE] <INFO> LedDevice 'apa102' found.
    [hyperiond LEDDEVICE] <DEBUG> <ProviderSpi.cpp:55:eek:pen()> _baudRate_Hz [1000000], _latchTime_ms [1]
    [hyperiond LEDDEVICE] <DEBUG> <ProviderSpi.cpp:56:eek:pen()> _spiDataInvert [0], _spiMode [0]
    [hyperiond ComponentRegister] <DEBUG> <ComponentRegister.cpp:36:setNewComponentState()> Smoothing: enabled
    [hyperiond FLATBUFCONNECTION] <INFO> Connecting to Hyperion: 127.0.0.1:19401
    [hyperiond JSONSERVER] <DEBUG> <JsonServer.cpp:27:JsonServer()> Created instance
    [hyperiond EFFECTENGINE] <INFO> Run effect "Rainbow swirl fast" on channel 0
    [hyperiond JSONSERVER] <INFO> Started on port 19444
    [hyperiond FLATBUFSERVER] <INFO> Started on port 19400
    [hyperiond PROTOSERVER] <INFO> Started on port 19445
    [hyperiond WEBSERVER] <DEBUG> <WebServer.cpp:33:initServer()> Initialize Webserver
    [hyperiond WEBSERVER] <DEBUG> Previous line repeats 1 times
    [hyperiond EFFECTENGINE] <DEBUG> <EffectEngine.cpp:183:runEffectScript()> Start the effect: name [Rainbow swirl fast], smoothCfg [2]
    [hyperiond HYPERION] <DEBUG> <PriorityMuxer.cpp:158:registerInput()> Register new input 'System/EFFECT' with priority 0 as inactive
    [hyperiond HYPERION] <INFO> Initial foreground effect 'Rainbow swirl fast' started
    [hyperiond EFFECTENGINE] <INFO> Run effect "Warm mood blobs" on channel 254
    [hyperiond EFFECTENGINE] <DEBUG> <EffectEngine.cpp:183:runEffectScript()> Start the effect: name [Warm mood blobs], smoothCfg [2]
    [hyperiond HYPERION] <DEBUG> <PriorityMuxer.cpp:158:registerInput()> Register new input 'System/EFFECT' with priority 254 as inactive
    [hyperiond HYPERION] <INFO> Inital background effect 'Warm mood blobs' started
    [hyperiond HYPERION] <DEBUG> <PriorityMuxer.cpp:158:registerInput()> Register new input 'System/GRABBER' with priority 250 as inactive
    [hyperiond ComponentRegister] <DEBUG> <ComponentRegister.cpp:36:setNewComponentState()> Framegrabber: enabled
    [hyperiond BOBLIGHT] <DEBUG> <BoblightServer.cpp:28:BoblightServer()> Instance created
    [hyperiond ComponentRegister] <DEBUG> <ComponentRegister.cpp:36:setNewComponentState()> LED device: enabled
    [hyperiond Dispmanx] <DEBUG> <GrabberWrapper.cpp:49:start()> Grabber start()
    [hyperiond HYPERION] <INFO> Hyperion instance 'First LED Hardware instance' has been started
    [hyperiond WEBSERVER] <DEBUG> <WebServer.cpp:91:handleSettingsUpdate()> Apply Webserver settings
    [hyperiond WEBSERVER] <DEBUG> <WebServer.cpp:91:handleSettingsUpdate()> Apply Webserver settings
    [hyperiond WEBSERVER] <DEBUG> <WebServer.cpp:109:handleSettingsUpdate()> Set document root to: :/webconfig
    [hyperiond WEBSERVER] <DEBUG> Previous line repeats 1 times
    [hyperiond WEBSERVER] <INFO> Started on port 8090 name 'Hyperion Webserver'
    [hyperiond WEBSERVER] <DEBUG> <WebServer.cpp:175:handleSettingsUpdate()> Setup SSL certificate
    [hyperiond WEBSERVER] <DEBUG> <WebServer.cpp:191:handleSettingsUpdate()> Setup private SSL key
    [hyperiond WEBSERVER] <INFO> Started on port 8092 name 'Hyperion Webserver'
    [hyperiond HYPERION] <DEBUG> <PriorityMuxer.cpp:238:setInputImage()> Priority 250 is now active
    [hyperiond HYPERION] <DEBUG> <PriorityMuxer.cpp:333:setCurrentTime()> Set visible priority to 0
    [hyperiond HYPERION] <DEBUG> <PriorityMuxer.cpp:238:setInputImage()> Priority 0 is now active
    [hyperiond HYPERION] <DEBUG> <PriorityMuxer.cpp:198:setInput()> Priority 254 is now active
    [hyperiond HYPERION] <DEBUG> <PriorityMuxer.cpp:298:setCurrentTime()> Timeout clear for priority 0
    [hyperiond HYPERION] <DEBUG> <PriorityMuxer.cpp:333:setCurrentTime()> Set visible priority to 250
    ^C[hyperiond DAEMON] <DEBUG> <hyperiond.cpp:167:freeObjects()> Cleaning up Hyperion before quit.
    [hyperiond FLATBUFSERVER] <INFO> Stopped
    [hyperiond PROTOSERVER] <INFO> Stopped
    [hyperiond WEBSERVER] <INFO> Stopped Hyperion Webserver
    [hyperiond WEBSERVER] <INFO> Previous line repeats 1 times
    [hyperiond HYPERION] <INFO> Hyperion instance 'First LED Hardware instance' has been stopped
    [hyperiond LedDeviceWrapper] <INFO> LedDevice 'apa102' closed
    [hyperiond Dispmanx] <DEBUG> <GrabberWrapper.cpp:57:stop()> Grabber stop()
    [hyperiond Dispmanx] <DEBUG> <GrabberWrapper.cpp:43:~GrabberWrapper()> Close grabber: Dispmanx
    [hyperiond V4L2:auto] <DEBUG> <GrabberWrapper.cpp:57:stop()> Grabber stop()
    [hyperiond V4L2:auto] <DEBUG> <GrabberWrapper.cpp:43:~GrabberWrapper()> Close grabber: V4L2:auto
    [hyperiond MAIN] <INFO> Application closed with code 0
    [hyperiond DAEMON] <DEBUG> <PythonInit.cpp:58:~PythonInit()> Cleaning up Python interpreter

    EDIT: gerade gesehen, dass du deinen Post abgeändert hast... sobald du mir ne neue Version schickst kann ich diese gerne testen... :)
     
  19. Paulchen-Panther

    Paulchen-Panther Moderator Staff Member Developer

    Messages:
    857
    Hardware:
    RPi1/Zero, RPi3, 32/64bit, +Arduino, +nodeMCU/ESP8266
    Diese version funktioniert nur wenn du sie manuell startest. Dann solltest du schon mal auf das WebUI kommen.
     
  20. u20p17

    u20p17 New Member

    Messages:
    18
    Nach nem manuellen Start komme ich wieder aufs Web interface! Danke dir!

    Wie mach ich es am besten, dass Hyperion.ng wieder automatisch gestartet wird?

    LG