1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

BUG Hyperion Raspberry PI 4 4K h265 HDMI Signal drop

Discussion in 'Bug Reports' started by Gary, 26 July 2019.

  1. GTAler

    GTAler New Member

    Messages:
    11
    Any solutions there?
     
  2. Johnny

    Johnny New Member

    Messages:
    8
    Any solutions there?
     
  3. Mitch7391

    Mitch7391 Member

    Messages:
    45
    Hardware:
    RPi3
    Doesn’t seem like it without setting your RPi4 to 1080p instead of 4K... So frustrating...
     
  4. eyk107

    eyk107 New Member

    Messages:
    12
    Could any developer please clarify this bug? Is it because of the firmware from the Rpi4 or is it a bug in Hyperion.ng?
     
    • Like Like x 1
  5. Mitch7391

    Mitch7391 Member

    Messages:
    45
    Hardware:
    RPi3
  6. GTAler

    GTAler New Member

    Messages:
    11
    Was könnte als Lösung dienen? Jemand einen Vorschlag?
     
  7. Johnny

    Johnny New Member

    Messages:
    8
    I have a solution !!! (1080p TV)

    Go into your json file and increase your width/height from 64 to 512.

    Now all my netflix videos working with internal grabber!
     
  8. pho08

    pho08 Member

    Messages:
    38
    thanks again (crossposting from LE forums :D)

    but can anyone explain what the width/height setting actually does? i don't quite understand


    :edit
    this "fix" also works with Hyperion.NG
    i set width/height to 640x360 (default is 80x45 here) and there is no more HDMI signal drop when playing 1080p 25fps / 50hz
     
    Last edited: 20 March 2020
  9. GTAler

    GTAler New Member

    Messages:
    11
  10. harun

    harun Member

    Messages:
    168
    Hardware:
    RPi3
    johnny,

    does you rpi4 works with hyperion?
     
  11. wars

    wars New Member

    Messages:
    7
    Hardware:
    RPi3, +nodeMCU/ESP8266
    I also have the issue with my Pi4 and 720p & 1080p video's. Already tried to change the width/height, but makes no difference.
    On my Pi3 I had the same issues, but less. Sometimes it seems like a hdmi handshake issue with my receiver. But as soon as I turn off the internal grabber it's working fine again. External grabber is always working fine.
     
  12. harun

    harun Member

    Messages:
    168
    Hardware:
    RPi3
    Is your tv 4k?
    What is your screen resolution for kodi?
    Did you whitelist 4k 24 and 23,98hz?
     
  13. wars

    wars New Member

    Messages:
    7
    Hardware:
    RPi3, +nodeMCU/ESP8266
    No, I don't have a 4k tv. All signals are going through my AV. I never setup any whitelisting. Is this needed?
     
  14. harun

    harun Member

    Messages:
    168
    Hardware:
    RPi3
    If you have no 4k I do not think you need to whitelist.

    maybe try it to whitelist [email protected] 60, 59,94, 50, 23,98 and 24. Bevause the internal grabber got issues by some refresh rate on the pi4.
     
  15. Puck

    Puck Member

    Messages:
    45
    Hardware:
    RPi1/Zero, RPi3, +nodeMCU/ESP8266
    So from what I understand there is no solution yet for proper running 4k content with Hyperion through software grabbing? It works perfectly for all my content 1080p or lower, even streaming services like Netflix. But I have some 4k content and would of course love to turn on Hyperion when watching that.

    However I also get the HDMI signal drops and green LEDs and so far nothing I've read and done have fully fixed this. Is this a known limitation and is it being worked on? Or are there no plans to support 4k properly (on a Pi 4) using software grabbing?
     
  16. harun

    harun Member

    Messages:
    168
    Hardware:
    RPi3
    Puck,

    If I am not wrong I read on forum of Le that this problem is by rpi foundation and not by Le.

    so hope that they will come with some fix.
     
  17. Puck

    Puck Member

    Messages:
    45
    Hardware:
    RPi1/Zero, RPi3, +nodeMCU/ESP8266
    Yeah I seem to have read something about that as well. But 4k works fine without Hyperion so I guess running both causes the issue somehow?
     
  18. harun

    harun Member

    Messages:
    168
    Hardware:
    RPi3
    The rpi4 is different that all the pi’s they came out. Because the FHD to 4k

    so this is very new product for rpi self. They need to figure things out. Thats the thing what I also read.

    what I dont understand is: why could we not set our resolution on 3840*2160
    Without hyperion on it.
     
  19. Puck

    Puck Member

    Messages:
    45
    Hardware:
    RPi1/Zero, RPi3, +nodeMCU/ESP8266
    What do you mean? 4k runs fine without Hyperion enabled.
     
  20. harun

    harun Member

    Messages:
    168
    Hardware:
    RPi3
    Screen resolution of kodi itself. Why is 3840x2160 not possible. If we set to that then we get errors with freezing