1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

RPi + OSMC KodiCheck error and lighting problems

Discussion in 'Software Support' started by morrigan, 1 April 2019.

  1. morrigan

    morrigan New Member

    Messages:
    1
    Hardware:
    RPi3, +Arduino
    Hello everyone,

    I am in need of help setting up my ambilight for my tv from multiple HDMI sources. I am using this tutorial provided by this guy from youtube


    I am using exact same things he listed except for my hdmi switcher and splitter.
    After booting up raspberry pi 3 for a few seconds, the lightings would form a snake-like show and then the lights would just go off like that except for some (picture below).

    [​IMG]

    I am hard stuck in this situation with no linux/raspberry/arduino knowledges to start with. This is the log I'm getting:
    Code:
    SSH Traffic:
    ssh connected
    sftp Send Hyperion Config - Sourcepath: C:/Users/Elite/Downloads, Targetpath: /etc/hyperion/, Filename: hyperion.config.json
    ssh disconnected
    ssh connected
    ssh out:     sudo journalctl -u hyperion.service 2>/dev/null
    ssh in:     -- Logs begin at Mon 2019-04-01 04:04:30 EDT, end at Mon 2019-04-01 04:06:33 EDT. --
    ssh in:     Apr 01 04:04:39 osmcAllie hyperiond[284]: Hyperion Ambilight Deamon (284)
    ssh in:     Apr 01 04:04:39 osmcAllie hyperiond[284]: Version   : V1.03.0 (GitHub-b8f7642/c5d5f2d-1465599599
    ssh in:     Apr 01 04:04:39 osmcAllie hyperiond[284]: Build Time: Jun 11 2016 01:39:39
    ssh in:     Apr 01 04:04:41 osmcAllie hyperiond[284]: INFO: Selected configuration file: /etc/hyperion/hyperion.config.json
    ssh in:     Apr 01 04:04:41 osmcAllie hyperiond[284]: HYPERION INFO: ColorTransform 'default' => [0; 299]
    ssh in:     Apr 01 04:04:41 osmcAllie hyperiond[284]: HYPERION INFO: ColorCorrection 'default' => [0; 299]
    ssh in:     Apr 01 04:04:41 osmcAllie hyperiond[284]: HYPERION INFO: ColorAdjustment 'default' => [0; 299]
    ssh in:     Apr 01 04:04:41 osmcAllie hyperiond[284]: LEDDEVICE INFO: configuration:
    ssh in:     Apr 01 04:04:41 osmcAllie hyperiond[284]: {
    ssh in:     Apr 01 04:04:41 osmcAllie hyperiond[284]: "colorOrder" : "rgb",
    ssh in:     Apr 01 04:04:41 osmcAllie hyperiond[284]: "delayAfterConnect" : 0,
    ssh in:     Apr 01 04:04:41 osmcAllie hyperiond[284]: "name" : "MyHyperionConfig",
    ssh in:     Apr 01 04:04:41 osmcAllie hyperiond[284]: "output" : "/dev/ttyACM0",
    ssh in:     Apr 01 04:04:41 osmcAllie hyperiond[284]: "rate" : 500000,
    ssh in:     Apr 01 04:04:41 osmcAllie hyperiond[284]: "type" : "adalight"
    ssh in:     Apr 01 04:04:41 osmcAllie hyperiond[284]: }
    ssh in:     Apr 01 04:04:41 osmcAllie hyperiond[284]: Opening UART: /dev/ttyACM0
    ssh in:     Apr 01 04:04:41 osmcAllie hyperiond[284]: HYPERION INFO: Json forward to 127.0.0.1:19446
    ssh in:     Apr 01 04:04:41 osmcAllie hyperiond[284]: HYPERION INFO: Proto forward to 127.0.0.1:19447
    ssh in:     Apr 01 04:04:41 osmcAllie hyperiond[284]: INFO: Creating linear smoothing
    ssh in:     Apr 01 04:04:41 osmcAllie hyperiond[284]: HYPERION (CS) INFO: Created linear-smoothing(interval_ms=50;settlingTime_ms=200;updateDelay=0
    ssh in:     Apr 01 04:04:42 osmcAllie hyperiond[284]: EFFECTENGINE INFO: 27 effects loaded from directory /usr/share/hyperion/effects
    ssh in:     Apr 01 04:04:42 osmcAllie hyperiond[284]: EFFECTENGINE INFO: Initializing Python interpreter
    ssh in:     Apr 01 04:04:43 osmcAllie hyperiond[284]: INFO: Hyperion started and initialised
    ssh in:     Apr 01 04:04:43 osmcAllie hyperiond[284]: INFO: Kodi checker created and started
    ssh in:     Apr 01 04:04:43 osmcAllie hyperiond[284]: INFO: Json server created and started on port 19444
    ssh in:     Apr 01 04:04:43 osmcAllie hyperiond[284]: PROTOCONNECTION INFO: Connecting to Hyperion: 127.0.0.1:19447
    ssh in:     Apr 01 04:04:43 osmcAllie hyperiond[284]: INFO: Proto server created and started on port 19445
    ssh in:     Apr 01 04:04:43 osmcAllie hyperiond[284]: V4L2GRABBER INFO: width=720 height=480
    ssh in:     Apr 01 04:04:43 osmcAllie hyperiond[284]: V4L2GRABBER INFO: pixel format=YUYV
    ssh in:     Apr 01 04:04:43 osmcAllie hyperiond[284]: BLACKBORDER INFO: threshold set to 0 (0)
    ssh in:     Apr 01 04:04:43 osmcAllie hyperiond[284]: BLACKBORDER INFO: mode:default
    ssh in:     Apr 01 04:04:43 osmcAllie hyperiond[284]: V4L2GRABBER INFO: signal threshold set to: {0,0,0}
    ssh in:     Apr 01 04:04:43 osmcAllie hyperiond[284]: V4L2GRABBER INFO: started
    ssh in:     Apr 01 04:04:43 osmcAllie hyperiond[284]: INFO: V4L2 grabber created and started
    ssh in:     Apr 01 04:04:43 osmcAllie hyperiond[284]: KODICHECK ERROR: Kodi Connection error (0)
    ssh in:     Apr 01 04:04:43 osmcAllie hyperiond[284]: BORDER SWITCH REQUIRED!!
    ssh in:     Apr 01 04:04:43 osmcAllie hyperiond[284]: CURRENT BORDER TYPE: unknown=0 hor.size=0 vert.size=0
    ssh in:     Apr 01 04:05:01 osmcAllie hyperiond[284]: KODICHECK ERROR: Kodi Connection error (0)
    ssh in:     Apr 01 04:05:12 osmcAllie hyperiond[284]: KODICHECK ERROR: Kodi Connection error (0)
    ssh in:     Apr 01 04:05:22 osmcAllie hyperiond[284]: KODICHECK ERROR: Kodi Connection error (0)
    ssh in:     Apr 01 04:05:32 osmcAllie hyperiond[284]: KODICHECK ERROR: Kodi Connection error (0)
    ssh in:     Apr 01 04:05:42 osmcAllie hyperiond[284]: KODICHECK ERROR: Kodi Connection error (0)
    ssh in:     Apr 01 04:05:52 osmcAllie hyperiond[284]: KODICHECK ERROR: Kodi Connection error (0)
    ssh in:     Apr 01 04:06:02 osmcAllie hyperiond[284]: KODICHECK ERROR: Kodi Connection error (0)
    ssh in:     Apr 01 04:06:12 osmcAllie hyperiond[284]: KODICHECK ERROR: Kodi Connection error (0)
    ssh in:     Apr 01 04:06:22 osmcAllie hyperiond[284]: KODICHECK ERROR: Kodi Connection error (0)
    ssh in:     Apr 01 04:06:32 osmcAllie hyperiond[284]: KODICHECK ERROR: Kodi Connection error (0)
    
    
    And this is my hyperion config: https://puu.sh/D8nHB/91ff3286f9.json
    Where did I go wrong?
     
  2. Arakon

    Arakon Member

    Messages:
    151
    Hardware:
    RPi1/Zero, RPi3, +Arduino
    Did you check if your Arduino sketch actually is set to 500000 baud?
    Also, you may have to change ttyACM0 to ttyUSB0 in the hyperion config.