1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Projet Hyperion Raspberry 3B + WS2812b

Discussion in 'French Talk' started by polochon37, 28 April 2020.

  1. polochon37

    polochon37 Member

    Messages:
    60
    Hardware:
    RPi3
    Hello,

    j'ai tout reçu mais je me suis cassé la clavicule, alors les tests sont limités....

    Le premier essai sur hyperion.NG :

    essai.png 2020_06_19_09_28_57_Netflix.png

    j'ai une image moche... avec n'importe quelle résolution.

    Pour info je suis en [email protected] en sortie sur ma TV :whistle::cool:
     
  2. polochon37

    polochon37 Member

    Messages:
    60
    Hardware:
    RPi3
    C'est bon, coup de chance sur le paramètre :
    Size decimationThe factor of size decimation. 1 means no decimation (keep original size)
    Il était à 8 j'ai mis 1
    2020-06-19 09_53_59-Netflix.png

    Bon les couleurs sont pas ouf mais ça doit se calibrer j'imagine ?
     
  3. NeeeeB

    NeeeeB Active Member

    Messages:
    159
    Hardware:
    RPi3, +Arduino, +nodeMCU/ESP8266
    Pour la décimation tu peux réduire jusque 4, ce n'est pas essentiel d'avoir une image "propre" sur la preview et surtout en augmentant la décimation tu réduis la charge mémoire sur le Pi.
    Moi par exemple si je met à 1, il freeze au bout d'un moment, manque de ram (j'ai un pi 3).
    Pour ce qui est des couleurs oui tu peux tout régler depuis l'interface web, ça prend un peu de temps mais une fois que c'est fait, c'est tout bon.

    Je t'invite à jeter un oeil ici:
    https://hyperion-project.org/wiki/Color-Calibration

    C'est pour Hypercon mais c'est valable également pour Hyperion.ng et surtout tu trouveras les liens vers les images de calibration des couleurs ;-)
     
  4. polochon37

    polochon37 Member

    Messages:
    60
    Hardware:
    RPi3
    Effectivement je me suis rendu compte que ça chauffait pas mal en 1 !
    Avec des pertes de synchro sur l'interface.... (Pi 3b+)
     
  5. polochon37

    polochon37 Member

    Messages:
    60
    Hardware:
    RPi3
    • Like Like x 1
  6. polochon37

    polochon37 Member

    Messages:
    60
    Hardware:
    RPi3
    J’y suis presque, Il me reste à régler ce problème de flash :


    En gros : => la connexion en direct c'est pas top, que j'essaye en GPIO10 ou GPIO12 ou GPIO18 j'ai des comportements étranges
     
  7. NeeeeB

    NeeeeB Active Member

    Messages:
    159
    Hardware:
    RPi3, +Arduino, +nodeMCU/ESP8266
    Je n'ai pas ces problèmes mais je passe par un Arduino Uno branché en USB sur le Pi...
     
  8. polochon37

    polochon37 Member

    Messages:
    60
    Hardware:
    RPi3
    J'ai un arduino uno aussi pour un autre projet et il fonctionne parfaitement avec le même strip...
    Si tu as un tuto avec l'arduino je suis preneur !
     
    Last edited: 29 June 2020
  9. polochon37

    polochon37 Member

    Messages:
    60
    Hardware:
    RPi3
    Bon tout est OK sur GPIO12 :) je suis content.
    Une astuce pour les coins dans le LED layout ?
    Sachant que j'aurais des connecteurs en L, il faut mettre un Edge Gap ?
     
  10. NeeeeB

    NeeeeB Active Member

    Messages:
    159
    Hardware:
    RPi3, +Arduino, +nodeMCU/ESP8266
    Pas d'astuce malheureusement...
    Dans Hypercon on pouvait gérer ce genre de truc mais avec Hyperion.NG je n'ai pas trouvé comment faire.
     
  11. polochon37

    polochon37 Member

    Messages:
    60
    Hardware:
    RPi3
    Testé Youtube HDR, ça fonctionne, donc splitter HDR ok !
     
  12. NeeeeB

    NeeeeB Active Member

    Messages:
    159
    Hardware:
    RPi3, +Arduino, +nodeMCU/ESP8266
    Celui d'aliexpress ? Parce que j'ai commandé le même du coup ^^
     
  13. polochon37

    polochon37 Member

    Messages:
    60
    Hardware:
    RPi3
    Yes j'avais renvoyé l'autre à Amazon.
    Je passe par l'appli Youtube de ma box SFR, vidéo 4K HDR, j'imagine que le test est bon !?
     
    • Like Like x 1
  14. NeeeeB

    NeeeeB Active Member

    Messages:
    159
    Hardware:
    RPi3, +Arduino, +nodeMCU/ESP8266
    Je pense oui
     
    • Like Like x 1
  15. NeeeeB

    NeeeeB Active Member

    Messages:
    159
    Hardware:
    RPi3, +Arduino, +nodeMCU/ESP8266
    Je viens de recevoir le mien, le même que toi donc, pourrais tu me donner ta config EDID pour avoir 4k sur une sortie et 1080 sur l'autre ? je ne suis pas certain de bien comprendre les instructions sur le boitier et je n'ai pas eu de manuel avec.

    Autre chose, j'ai commandé ça :
    https://fr.aliexpress.com/item/4000917130635.html?spm=a2g0s.9042311.0.0.701b6c37QiJ8sP
    Il me semble avoir compris que tu avais le même également, tu me confirmes que ça fonctionne sans souci ?

    Je ne peux pas tester pour le moment, j'attend mon Pi4 et surtout je n'ai pas (encore) de TV 4K, mais je prépare mon installation pour quand je vais y passer.
    Merci !
     
  16. AdReD

    AdReD New Member

    Messages:
    12
    Hardware:
    RPi3, +Arduino
    Oh yeah. I have the same grabber. https://www.aliexpress.com/item/4000917852728.html?spm=a2g0s.9042311.0.0.6f7c4c4diybjfy
    And it works wonderfully. I just uploaded a video in the next thread where our grabber is used.
    https://hyperion-project.org/threads/xxl-setup-rpi4-apa102-ambilight.10622/#post-26536
     
    • Like Like x 2
  17. polochon37

    polochon37 Member

    Messages:
    60
    Hardware:
    RPi3
    Heu en fait que mette n'importe quoi en 4K ça fonctionne bien avec grabber.
    Après il y a le plan au dos pour les 1 et 0 !!
    Là je tourne en 000, le output 2 est en 1080p !

    Je n'ai pas le même mais apparemment il fonctionne bien !!
     
    • Like Like x 1
  18. NeeeeB

    NeeeeB Active Member

    Messages:
    159
    Hardware:
    RPi3, +Arduino, +nodeMCU/ESP8266
    Ouais j'ai bien vu le schéma sur le boîtier mais c'est pas super clair...mais bon si tu me dis que ça marche en 000 bah je verrai bien ahah
    Merci !
     
  19. serw29

    serw29 New Member

    Messages:
    8
    Hardware:
    RPi3
    Salut, je vois que tu utilises le grabber : 1 video grabber Nsendato UTVF007 USB 2.0 vers HDMI : € 13,89 : https://fr.aliexpress.com/item/32828134783.html, tu as réussi sans souci à le faire reconnaitre ?

    J'ai pris le même et quand je fais un lsub, il m'indique juste : Bus 001 Device 007: ID 534d:0021 et du coup sous hyperion j'ai une erreur de signal au lancement.
     
  20. polochon37

    polochon37 Member

    Messages:
    60
    Hardware:
    RPi3
    Tu es sous hyperion NG ?
    Je n’ai eu aucun soucis de détection.

    tu peux éventuellement le démonter, pour voir la puce si c’c’est bien la bonne.