1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

HyperCon Rpi 4 + Raspbian + Hyperion + WS2812

Discussion in 'Software Support' started by Alen Kis, 24 March 2020.

  1. Alen Kis

    Alen Kis New Member

    Messages:
    2
    Hardware:
    RPi3, +Arduino, +PhilipsHue
    Hello,

    I need help, I understand this topic is made a few times on the forum and I didn't wanted to make another topic of the same content but nothing works for me. It could be that I'm missing something.

    For a start I have only basic knowledge about raspberry and its OS. As you could see in the title this is Raspberry Pi 4 related.

    My hardware is:
    Raspberry Pi 4 4GB rev.1.2
    Switching Power Supply 5v 10A
    WS2812B Led Strip (400 LEDs)
    But for testing, I'm using small stripe cutoff with 8 LEDs on it.

    Connection:
    A connection is done the same as for Rpi 3b+.

    Negative (-) from the power supply is connected to negative on WS2812 strip and to pin 6 (GND) on Rpi. Positive (+) from the power supply is connected just to positive (5v+) on WS2812 strip. Data from WS2812 is connected to pin 12 (GPIO 18) on Rpi.

    OS:
    For OS I'm using newest Raspbian Booster (also tried newest LibreElec, ended up with same result and error)

    Hyperion:
    Tried both terminal-based installation and with HyperCon

    An error that I'm getting is:
    Unable to initialize RPI_WS281X
    and after copying Hyperiond file from your last post in this thread:

    https://hyperion-project.org/threads/rpi-4-unable-to-initialize-ws281x-library.3680/

    I'm getting that error is "signal".

    I also tried the suggestion "storage/output.txt" from the tread mentioned above. The output is provided bellow .

    Interesting thing is that after a few tries I wanted to check with some other tutorials just for WS281X and followed this one:

    https://tutorials-raspberrypi.com/connect-control-raspberry-pi-ws2812-rgb-led-strips/

    I had to additionally install scons and swig in order for this tutorial to work but in the end, it worked without a problem, all effects were visible on 8 led stripe.

    I tried Hyperion again and still nothing.
    I'm not sure why is this RPI_WS281X tutorial working but Hyperion won't.


    Edit:

    Corrected tutorial link, corrected grammar mistakes, provided links for log, config and output.

    Hyperion Log
    77

    Hyperion.config.json:


    Test file output:


    Thanks in advance for your time and help.
     
    Last edited: 25 March 2020
  2. Alen Kis

    Alen Kis New Member

    Messages:
    2
    Hardware:
    RPi3, +Arduino, +PhilipsHue
    Hyperion.ng same.

    [hyperiond LEDDEVICE] (ERROR) Device disabled, device 'ws281x' signals error: 'Unable to initialize ws281x library.'

     
    Last edited: 25 March 2020
  3. Troublebrewing

    Troublebrewing New Member

    Messages:
    1
    Hardware:
    RPi1/Zero
    Alen,

    I have been running into a similar situation with beta 4 of Hyperion.ng on a pi zero w. The rpi_ws281x library test worked fine but hyperion couldn't start the device driver.
    I tried all of the suggestions from the rpi_ws281x readme found here https://github.com/jgarff/rpi_ws281x but no improvement. I tried compiling hyperion.ng with the latest updates to rpi_ws281x, but still no luck.

    The last fix I tried was detailed in this closed issue on the hyperion.ng github repo. Essentially, hyperion needed to be run as root rather than as pi. It doesn't go into detail as to why, but gives the commands to change it persistantly. This finally seems to have done the trick for me. I havent tested it fully to see if everything is working, but hopefully it will help.