1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

RPi + OSMC RPi3b+with APA102+OSMC

Discussion in 'Software Support' started by TinmanXO, 16 June 2020.

  1. TinmanXO

    TinmanXO New Member

    Messages:
    5
    Hardware:
    RPi3
    For the life of me, I cannot get this working and I'm usually good with these things. I would love to be able to knock this project out because i have multiple on going. So, any help is HIGHLY appreciated.

    My specs:
    RPi3ModelB with OSMC
    APA102 LED
    Avedio links HDMI splitter (powered)
    GANA HDMI to RCA (has a port but not powered in my setup.. also set to PAL)
    Tried an easyday DC60 then ordered Lightberry USB grabber
    I also have a 5v buffer to boost the signal for LEDs
    PHEVOS 5v 60 watt power supply

    I might also add, that i checked voltages along the LED and they were reading 5v besides the Data line
     
  2. TPmodding

    TPmodding Administrator Staff Member Administrator

    Messages:
    1,890
    Hardware:
    RPi1/Zero, RPi2, RPi3, +Arduino, +nodeMCU/ESP8266
    ok, should we guess now some issues which COULD be the problem, or do you provide us some logs?
     
    • Like Like x 1
  3. TinmanXO

    TinmanXO New Member

    Messages:
    5
    Hardware:
    RPi3
    ssh in: Jun 16 11:57:50 osmc systemd[1]: hyperion.service: Service hold-off time over, scheduling restart.
    ssh in: Jun 16 11:57:50 osmc systemd[1]: Stopped Hyperion ambient light systemd service.
    ssh in: Jun 16 11:57:50 osmc systemd[1]: Started Hyperion ambient light systemd service.
    ssh in: Jun 16 11:57:50 osmc systemd[1]: hyperion.service: Main process exited, code=exited, status=210/CHROOT
    ssh in: Jun 16 11:57:50 osmc systemd[1]: hyperion.service: Unit entered failed state.
    ssh in: Jun 16 11:57:50 osmc systemd[1]: hyperion.service: Failed with result 'exit-code'.
    ssh out: sudo systemctl stop hyperion.service 2>/dev/null; sudo /etc/init.d/hyperion stop 2>/dev/null ; sudo /sbin/initctl stop hyperion 2>/dev/null
    sftp Send Hyperion Config - Sourcepath: C:/Users/Brad/Desktop, Targetpath: /etc/hyperion/, Filename: hyperion.config.json
    ssh out: sudo systemctl stop hyperion.service 2>/dev/null; sudo /etc/init.d/hyperion stop 2>/dev/null ; sudo /sbin/initctl stop hyperion 2>/dev/null
    ssh out: sudo systemctl start hyperion.service 2>/dev/null ; sudo /etc/init.d/hyperion start 2>/dev/null ; sudo /sbin/initctl start hyperion 2>/dev/null

    Edit: I will also add that i was getting these same null messages with hyperion and now i have hyperion.ng installed. Hypercon still works with hyperion.ng right?
     
  4. TPmodding

    TPmodding Administrator Staff Member Administrator

    Messages:
    1,890
    Hardware:
    RPi1/Zero, RPi2, RPi3, +Arduino, +nodeMCU/ESP8266
    • Thank you Thank you x 1
  5. TinmanXO

    TinmanXO New Member

    Messages:
    5
    Hardware:
    RPi3
    Okay so i didn't install hyperion thru hypercon. Only sent the config file. But with this new way, i would need a browser on the OS so it wouldn't work with OSMC?

    Edit: i will try this config. What is the command for putty to get the log for if i try this and it doesn't work?
     
    Last edited: 17 June 2020
  6. TPmodding

    TPmodding Administrator Staff Member Administrator

    Messages:
    1,890
    Hardware:
    RPi1/Zero, RPi2, RPi3, +Arduino, +nodeMCU/ESP8266
    no you can also use your browser on your laptop/pc/mobile whatever

    log is also in the webinterface
     
    • Thank you Thank you x 1