1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

HyperCon SIGINT when starting hyperiond

Discussion in 'Software Support' started by wneessen, 1 April 2019.

  1. wneessen

    wneessen New Member


    I've been running hyperiond on a Raspberry Pi for more than a year now. Today I switch out my network router and setup up a new IP range for my local network. After the configuration was done, I noticed, that the RasPi acquired a new IP w/o issues, but the hyperiond wasn't working.

    After logging in via SSH I tried to start it using systemd/systemctl, without succes. So I tried to run it manually, but every time I try, I receive a "Illegal instruction" (SIGILL) signal and the service refuses to start.

    gdb gives the following backtrace:
    $ sudo gdb /opt/hyperion/bin/hyperiond
    GNU gdb (Raspbian 7.7.1+dfsg-5) 7.7.1
    Copyright (C) 2014 Free Software Foundation, Inc.
    License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
    This is free software: you are free to change and redistribute it.
    There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
    and "show warranty" for details.
    This GDB was configured as "arm-linux-gnueabihf".
    Type "show configuration" for configuration details.
    For bug reporting instructions, please see:
    Find the GDB manual and other documentation resources online at:
    For help, type "help".
    Type "apropos word" to search for commands related to "word"...
    Reading symbols from /opt/hyperion/bin/hyperiond...(no debugging symbols found)...done.
    (gdb) run
    Starting program: /opt/hyperion/bin/hyperiond
    [Thread debugging using libthread_db enabled]
    Using host libthread_db library "/lib/arm-linux-gnueabihf/libthread_db.so.1".
    Application build time: Mar 15 2016 13:18:29
    Program received signal SIGILL, Illegal instruction.
    0x76114700 in QVariant::clear() () from /usr/lib/arm-linux-gnueabihf/libQtCore.so.4
    (gdb) bt
    #0  0x76114700 in QVariant::clear() () from /usr/lib/arm-linux-gnueabihf/libQtCore.so.4
    #1  0x761160e4 in QVariant::operator=(QVariant const&) () from /usr/lib/arm-linux-gnueabihf/libQtCore.so.4
    #2  0x76006470 in QLocalePrivate::updateSystemPrivate() () from /usr/lib/arm-linux-gnueabihf/libQtCore.so.4
    #3  0x76006b68 in ?? () from /usr/lib/arm-linux-gnueabihf/libQtCore.so.4
    #4  0x76006c04 in QLocale::QLocale() () from /usr/lib/arm-linux-gnueabihf/libQtCore.so.4
    #5  0x76096c40 in ?? () from /usr/lib/arm-linux-gnueabihf/libQtCore.so.4
    Backtrace stopped: previous frame identical to this frame (corrupt stack?)
    Any idea, how to fix this?