1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

RPi + Other Software USBTV007 Direct Grabber is not working with rpi1

Discussion in 'Hardware Support' started by violentstorm, 9 April 2020.

  1. violentstorm

    violentstorm New Member

    Messages:
    3
    Hardware:
    RPi1/Zero
    Hi there,

    I'm using hyperion now for many years with different hardware but only with internal grabber.
    Now I want to expand the setup:

    I have bought a HDMI Splitter and a USB HDMI Grabber

    so now my chain is:
    Ordoid C2 (Coreelec),PS3,PC --->AV Reciever --> HDMI splitter -->TV and USB HDMI grabber on RPi1 with WS2801

    Splitter, Odroid C2, RPi1 and WS2801 are all using the same power supply

    Without the USB Grabber connected every thing is working fine:
    Nice Picture on the TV, CEC from the TV Remote through the reciever to Coreelec

    But If I connect the USB grabber the Troble begins:
    Sometimes CEC is only working down to the reciever, not to the Odroid
    The grabber is not able to capture a picture.

    The RPi1 runs a Dietpi and I installed hyperion via the installscript. Config was done via hypercon.
    At Bootup the rainbow-effect shows up.

    Output from lsusb for the grabber is
    Fushicai USBTV007 Video Grabber [EasyCAP]

    I have tried with different sources and also tried the USB grabber on my laptop, no difference.

    Sadly I've got no second display, to test if simply the splitter is not working.

    If I connect the Grabber directly with the Odroid, nothing changes.

    How could I debug the grabber further?
     
  2. violentstorm

    violentstorm New Member

    Messages:
    3
    Hardware:
    RPi1/Zero
    I contacted the seller and changed the grabber, he confirmed the faulty unit and send me a new one.

    The new works with my notebook, but not with my rpi1. I tested a new sdcard with clean raspberian lite and hyperion-ng 2.0.0.6. Still no picture.
    So I tested a rpi2 with clean raspberian lite and hyperion-ng 2.0.0.6 and it works. GREAT :-D
    But my rpi2 is reserved for another project. How could I investigate why my rpi1 is not working?
     
    Last edited: 4 June 2020