1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

RPi + Other Software Video output problems with AppleTv

Discussion in 'Hardware Support' started by Supersimo88, 18 May 2017.

  1. Supersimo88

    Supersimo88 New Member

    Messages:
    11
    Hardware:
    RPi1/Zero, +nodeMCU/ESP8266
    I find myself with a problem with AppleTv 4th.
    My setup is like the picture below but i use ws2812b led.
    All my sources go in a AV receiver and then enter the hdmi switch, so I can use more sources and get the most out of my audio system.
    If I turn on AppleTv with both hdmi cables coming out of the switch connected, the LEDs work but I have no screen image, but if before switching on the appleTv I unplug the hdmi cable that goes to the hdmi2av I have no problem seeing the Image, so my temporary solution is to disconnect the hdmi cable, turn on teh AppleTv and reconnect the cable to the hdmi2av, so everything works as it should, the fact is that it only happens with AppleTv, all other sources (xbox one and computers) do not have this problem.

    Since my tv is only 720p I tried to change the AppletTv output from Auto to 720p 60 thinking it could negotiate the resolution with the hdmi2av before that of the tv and therefore not allow the view on tv but things are not changed.

    Has anyone already had a similar problem or maybe the same thing and could you help me find a faster and more elegant solution than having to unplug the hdmi cable?

    I begin to suspect that the hdmi switch might be the cause or maybe the hdmi2av though strange thing that with the other sources the problem does not occur

    [​IMG]
     
    Last edited: 18 May 2017
  2. Supersimo88

    Supersimo88 New Member

    Messages:
    11
    Hardware:
    RPi1/Zero, +nodeMCU/ESP8266
    For those with an AV receiver, I think the problem is in hdmi2av, if I turn off the source and reboot, the converter does not take the signal, I need to turn it off, disconnect the hdmi, turn it on and reconnect the hdmi otherwise there is no signal on av out from hdmi2av.

    Did anyone have my own problem? Is the hdmi2av that I have to be defective?
     
  3. IKnowCodeSoup

    IKnowCodeSoup New Member

    Messages:
    12
    Hardware:
    RPi1/Zero, RPi2, RPi3, +Arduino, +PhilipsHue, +nodeMCU/ESP8266
    It's definitely not the switch? Tried swapping outputs and still the lights work but the Apple TV does not?

    There is what's called EDID. Exactly as you say the devices negotiate the resolution.
    It's common for HDMI devices (switches and the like) to not change once set.

    Perhaps the adapter is defaulting to 1080 when no signal is present.?

    I was thinking the adapter had a res selector but it's only NTSC / PAL. Have been dealing with a HDMI resolution nightmare for weeks...

    The only solution I've found that works is using a scaler (for instance when needing 4k output to the TV and 1080 to the adapter). Otherwise the maximum resolution that all devices support should be the one that's selected. In your case, it's odd that 720 is not being selected.

    The receiver is set to 720 output manually?
     
    Last edited: 24 August 2017