1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

SOLVED WS2813 LEDs not working?

Discussion in 'Hardware Support' started by Robin Koehler, 10 September 2019.

  1. Robin Koehler

    Robin Koehler New Member

    Hi all,

    Thank you for providing the project and this great community! Total noob here, I thought I had followed the official tutorial:
    (https://hyperion-project.org/threads/raspberry-pi-3-mediacenter-hyperion-ambilight-no-soldering.77/), however accidentally ended up with a set of 4-pin WS2813 LEDs instead (60/m, 184 total).

    I can't get the LEDs to light up at all. No boot sequence, no single colours, no white, nothing.

    I wired them up as per the diagram in the tutorial:

    I have the LEDs on GPIO pin 19 and 23 on the Pi as per the picture, ground is on pin 6 and going to external power supply (5V 10A). No arduino. No level shifter.

    Raspberry Pi4, latest Raspbian OS. Have everything installed including Hyperion as a service. Can connect to the service via HyperCon.

    I have selected the WS281X-SPI, but also tried other configurations. The config file gets sent via SSH correctly.

    Where can I start to troubleshoot this? I am completely new to LEDs and have a very basic understanding of electronics. I have not yet seen the LEDs light up yet, so I'm not sure if the strip is malfunctioning.

    Any help is greatly appreciated!

    Thank you kindly in advance,

  2. TPmodding

    TPmodding Administrator Staff Member Administrator

    RPi1/Zero, RPi2, RPi3, +Arduino, +nodeMCU/ESP8266
    you should just first do your researches...why did you ordered the ws2813b?

    do you know for what the GND BI DI and 5V stands?
  3. Robin Koehler

    Robin Koehler New Member

    Hi TPmodding! Thanks so much for your reply. Like I said, I am relatively new to the topic, and have exhausted the forum search as well as Google before posting here, so I really appreciate you answering my thread :) It's understandable that hearing some basic questions like these can be a bit frustrating if you are already familiar with these projects.

    I picked the official tutorial because it seemed relatively easy to follow. WS2801 LEDs were not available on Amazon or eBay in Australia, and I wanted 60 pixels / m, so that limited the options even further unfortunately. The WS2813 were what was sent to me (the eBay listing had a different description), but according to the info I gathered after they arrived, it actually is supported and seems like a great alternative due to the backup data line if a pixel ever fails.

    Back on topic though:
    I can post pictures of my wiring later tonight, however understand that CI, DI, Ground and 5V are equivalent to the WS2801 in the tutorial.

    I know now that the LEDs won't produce light if they are just plugged into power and that they need to be addressed by the controller.

    To the best of my knowledge, using the pin 19 for data and pin 23 for clock should do the trick.

    I have also installed the APA102 library and test python script (https://github.com/tinue/apa102-pi). The script runs, however the LEDs are still dark just like with Hyperion. The HyperCon log doesn't show any errors. I have enabled SPI in the Pi config file as well, made sure audio is routed to HDMI, and like I said the strip is powered by an external 5v10a supply on both ends of the strip with black for ground and red for 5v.

    What can I do to figure out what the problem is?

    Thanks again very much for your help!

  4. Akriss

    Akriss Active Member

    RPi1/Zero, RPi2, RPi3, 32/64bit, +Arduino, +nodeMCU/ESP8266
    The APA102 library is for a different led strip. Not for ws2813 strips.

    Ws2813 strips use the ws2812 library. three wire are used.

    Ws2813 strips have a extra date line for led failure. EX: If one led go's bad on a ws2812 strip every led after will fall as well. Not so on a ws2813 strip, just the bad led.

    The "BI" line is the Backup line. "DI" in the main date line.

    So the ws2813 strip is just a ws2812 strip with a backup line.

    I have no working experience with ws2813 strips but if you follow guide that use ws2812 strips, it should work.
    My experience with ws2812 library is the SPI version of the driver works a bit better then the PWM version.

    However I'm not sure if the BI line and DI line should be tie together and attached to the Rpi gpio pin. Or if you just use the DI line and let float the BI line.

    Hope its of help.
    Last edited: 12 September 2019
  5. Robin Koehler

    Robin Koehler New Member

    Hi Akriss,

    Ok that helps a lot! Thanks to this I'm starting to understand where some of my confusion is coming from. This is the strip I ordered:

    It is actually an APA102 o_O I will try the tool that you suggested in the other thread here https://hyperion-project.org/threads/solved-apa102-leds-do-not-light-on-rpi3-le-8-2-2-hyperion.2683/ and post photos tonight.

    The real issue here is that I am still learning about the LED types and that all the different names and numbers don't make sense to me yet. I will check my wiring a second time now that I at least know for certain it is an APA102 and will report back later today.

    Many thanks,

  6. Akriss

    Akriss Active Member

    RPi1/Zero, RPi2, RPi3, 32/64bit, +Arduino, +nodeMCU/ESP8266
    • Like Like x 1
  7. Robin Koehler

    Robin Koehler New Member

    Hi Akriss!

    Quick update: your comment actualy got me back on track, I now have a funcitoning system! I used the tester you suggested in the other thread to confirm the pins on the Pi, that was fine. Now that I knew it's an APA102 strip, I could focus on the wiring instead of the Hyperion config.

    I wired up the remaining cut of the 5m strip that I wasn't going to use, and managed to get it to light up after I reconnected power, ground, clock and data to it. I was satisfied knowing that the power supply is ok and that the Pi can actually control it too. I then checked my old wiring again, tightened the screws in the terminal box, re-fastened the power supply wiring and bam! That was all it took.

    Lessons learnt:

    1) Double check the exact type of LED strip
    2) Test strip prior to mounting to TV ;-)
    3) Check wiring if strip won't light up
    4) Confirm Pi pin connections

    I've colour calibrated the system tonight and it's gorgeous! Worth the struggle.

    Thanks everyone
    • Like Like x 2