1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Zwei Ziele in OpenELEC ansteuern (Stripe + HUE)... Wie?

Discussion in 'German Talk' started by berlinhimmel, 23 August 2016.

  1. berlinhimmel

    berlinhimmel Member

    Messages:
    54
    Hardware:
    RPi3, +PhilipsHue
    Ich habe vor einiger Zeit schon hier gelesen, dass man mit Hypercon zwei Ziele gemeinsam ansteuern kann und nun die Anleitung auch nochmal rausgekramt: https://hyperion-project.org/wiki/Controlling-Multiple-Devices

    Da steht dann aber auch bereits oben in Klammern "Raspbian" und auch die Pfade hauen so nicht hin unter OpenELEC.

    Wie kann ich nun meine Ambi-Stripes und HUE parallel laufen lassen bzw. geht das überhaupt unter OpenELEC? Und wenn OpenELEC nicht geht, ginge es unter OSMC?
     
  2. TPmodding

    TPmodding Administrator Staff Member Administrator

    Messages:
    1,888
    Hardware:
    RPi1/Zero, RPi2, RPi3, +Arduino, +nodeMCU/ESP8266
    geht auch unter openelec, du musst halt für jedes weiteres device eine hyperion-instanz laufen lassen mit eigener config natürlich :)
     
  3. Brindosch

    Brindosch Active Member

    Messages:
    658
    Hardware:
    RPi1/Zero, RPi2, RPi3, +nodeMCU/ESP8266
    OpenELEC wird im Wiki nicht beschrieben, weil es noch keiner nieder geschrieben hat :)
    Dupliziere in der autostart.sh den Startaufruf, nutze aber eine zweite Konfiguration (.json) die gestartet wird (in der die hue konfiguriert sind).
    Jetzt musst du nur noch den forwarder aktivieren (hyperion.config.json) der mit seinen ports auf die ports deiner hue configuration zielt.

    Fertig
    Viel Spaß
     
  4. berlinhimmel

    berlinhimmel Member

    Messages:
    54
    Hardware:
    RPi3, +PhilipsHue
    Prima... Danke für die Hinweise. Ich werde es dann mal testen.

    Soll ich mal eine Anleitung schreiben? Wenn ich es erfolgreich durchgeführt habe?
     
  5. Brindosch

    Brindosch Active Member

    Messages:
    658
    Hardware:
    RPi1/Zero, RPi2, RPi3, +nodeMCU/ESP8266
    Ja warum nicht, du kannst du sie hier im Forum schreiben, dann pinne ich sie oben an und Nutzer können Fragen an dich stellen :D
     
  6. berlinhimmel

    berlinhimmel Member

    Messages:
    54
    Hardware:
    RPi3, +PhilipsHue
    Netter Versuch ;-)

    Ich schau mal was ich tun kann und wie ich das unterbringe. Ich dokumentiere eh viel für mich selbst... Das dann ordentlich auszuschreiben und als Basis den Eintrag von eurem Wiki zu nehmen, ist dann ja nicht so schwer.
     
  7. Brindosch

    Brindosch Active Member

    Messages:
    658
    Hardware:
    RPi1/Zero, RPi2, RPi3, +nodeMCU/ESP8266
    Nein ernsthaft, ich kann nicht alles abdecken. :)
    Ich hätte nichts gegen ein Tut. @b1rdhous3 nutzt auch Hue, der ist aber schon eingespannt mit anderen Dingen :D Wobei der sicher hier und da nen Hinweis hat.
    Jedenfalls fragen die Leute regelmäßig danach, du würdest viele Fans haben :D
     
  8. berlinhimmel

    berlinhimmel Member

    Messages:
    54
    Hardware:
    RPi3, +PhilipsHue
    Naja, erstmal mein HUE richtig zum laufen bringen. Hatte gestern nach einiger Zeit mal wieder weiter gemacht, hatte aber irgendwie mit Ausfällen zu kämpfen. Sprich die Lampen blieben dann einfach aus. Auch ein Flimmern / Wabern hatte ich zum Teil, so als würde er nicht wissen woher er nun die Farben nehmen soll für die Darstellung.
    Mir fällt es etwas schwer, den Bereich genauer zu definieren von wo die Farben genommen werden soll für meine drei Lampen. Zum einen wie ich nun festlege von wo bis wo Infos für die Lampe gelten und zum anderen... Was soll die Lampe am Ende erfassen? Hab eine große Fläche von ca. 3 x 2 Metern (Leinwand) hinter der die LEDs an der Wand sind (http://powerpi.de/forum/viewtopic.php?f=13&t=2324).

    Gibt es eigentlich einen Weg, dass Hyperion nur auf bestimmte Farbtöne reagiert wie z.B. rot? Stelle mir gerade vor, wie z.B. bei einer Explosion die zusätzlichen HUE's aufleuchten. Oder wenn was mit Wasser zu sehen ist, das blau eben intensiver wird mittels der HUEs.

    Bin mir noch unsicher ob ich das am Ende so beibehalte vom Setup, aber ich experimentiere halt gern, wenn man schon was da hat.
     
  9. Brindosch

    Brindosch Active Member

    Messages:
    658
    Hardware:
    RPi1/Zero, RPi2, RPi3, +nodeMCU/ESP8266
    Da die zweite Konfiguration auch eine Kalibrierungs sparte enthält, kannst du auch hier kalibrieren, leider nur manuell momentan. Also komplett unabhängig von dem was du schon nutzt, da original bild.

    Herauszufinden wie groß die Bereiche sein sollen ist eine eigene Kunst :D
     
  10. berlinhimmel

    berlinhimmel Member

    Messages:
    54
    Hardware:
    RPi3, +PhilipsHue
    Dann kannst du mir doch bestimmt ein Denkanstoß geben wo und wie ich da den Filter manuell festlege. Muss ich dann z.B. einfach die Werte bei Grün und Blau auf 0 setzen (Weißwert)? Oder ist es besser, mit den Schwellenwerten zu arbeiten, wenn ich nur intensives rot, blau und grün erleben will?
    Im Quelltext rum zu werkeln, ist definitiv nicht das Problem :)
     
  11. Brindosch

    Brindosch Active Member

    Messages:
    658
    Hardware:
    RPi1/Zero, RPi2, RPi3, +nodeMCU/ESP8266
    Vom Weißwert geht alles aus, damit kannst du auch grob die allgemeine Helligkeit regulieren aber nicht mehr.
    Die Schwellenwerte sollten eigentlich dafür funktionieren, damit alles unten abgeschnitten wird.
     
  12. berlinhimmel

    berlinhimmel Member

    Messages:
    54
    Hardware:
    RPi3, +PhilipsHue
    Ich muss den Beitrag mal wieder aus dem Archiv kramen, denn ich habe vor nicht all zu langer Zeit das ganze Projekt auf OSMC umgezogen und dabei bisher die HUE Geschichte komplett vernachlässigt.

    Nun habe ich versucht, meine damaligen Infos wieder zusammen zu kratzen und konnte mich zum Teil auch wieder an Schritte erinnern und Einstellungen rekonstruieren.
    Doch scheitere ich derzeit mal wieder an dem Punkt die zwei Instanzen in den Autostart zu bringen und das sollten sie ja sein, damit sie gehen... oder?

    Ich hab mal salopp den Befehl
    Code:
    sudo /usr/bin/hyperiond /opt/hyperion/config/hyperion.config.hue.json
    eingegeben, erhalte dann aber in meiner SSH Verbindung zu OSM einen Fehler der lautet:

    Daraus schließe ich erst einmal, dass für diese Pfadangabe etwas nicht hinhaut und eine autostart.sh Datei kann ich in OSMC auch nicht finden (selbst Google lässt mich diesbezüglich etwas im Regen stehen).